9

I am running a Fedora 32 on my XPS 13 laptop. I use Chrome as my browser, and I have 2 profiles - work and personal. When I open a new profile, it opens a new Chrome window. However, both windows lag significantly. Opening a new tab takes about 10 seconds, scrolling is very slow, etc. The number of tabs open is insignificant. If I have a single window with 30 tabs, they all respond quickly; but if I have 2 windows with a single tab in each, they are both very slow.

It could not be due to limited resources, as I have 16 GB of RAM, and an 8-core i7. Checking the resource usage, all cores are at about 10%, and used memory is at about 4 GB with no swap used.

Firefox, on the other hand, behaves perfectly fine, even if I open a dozen windows.

When I run lshw -c video I see the proper driver installed - in my case, configuration: driver=i915 latency=0.

EDIT:

As suggested in the comments, Kernel version is 5.8.11, Mesa drivers version is 20.1.8.

Running cat /proc/cmdline yields the following result:

BOOT_IMAGE=(hd0,gpt7)/vmlinuz-5.8.11-200.fc32.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet systemd.unified_cgroup_hierarchy=0

Running dmesg -t --level=alert,crit,err,warn:

ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
usb: port power management may be unreliable
i8042: Warning: Keylock active
acpi PNP0C14:02: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
wmi_bus wmi_bus-PNP0C14:03: WQBC data block query control method not found
acpi PNP0C14:03: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
acpi PNP0C14:04: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
acpi PNP0C14:05: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
i2c_hid i2c-CUST0001:00: supply vdd not found, using dummy regulator
i2c_hid i2c-CUST0001:00: supply vddl not found, using dummy regulator
psmouse serio1: synaptics: Unable to query device: -5
systemd-journald[595]: File /run/log/journal/31e01750f14d4855bff7e16cfbc2e05e/system.journal corrupted or uncleanly shut down, renaming and replacing.
uvcvideo 1-5:1.0: Entity type for entity Extension 4 was not initialized!
uvcvideo 1-5:1.0: Entity type for entity Extension 3 was not initialized!
uvcvideo 1-5:1.0: Entity type for entity Processing 2 was not initialized!
uvcvideo 1-5:1.0: Entity type for entity Camera 1 was not initialized!
iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-cc-a0-56.ucode failed with error -2
iwlwifi 0000:02:00.0: api flags index 2 larger than supported by driver
iwlwifi 0000:02:00.0: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
thermal thermal_zone9: failed to read out thermal zone (-61)
psmouse serio1: Failed to enable mouse on isa0060/serio1
queueing ieee80211 work while going to suspend
queueing ieee80211 work while going to suspend
psmouse serio1: Failed to disable mouse on isa0060/serio1
done.
uvcvideo: Failed to query (GET_CUR) UVC control 11 on unit 2: -110 (exp. 1).
done.
done.
done.
done.
done.
done.
typec port1-partner: parent port1 should not be sleeping
done.

What could be the issue?

EDIT 2: I have since switched to Ubuntu 20.04.1 and I have no issues with Chrome whatsoever.

6
  • 1
    Are you running an up to date system? What's your kernel version? Do you have mesa-dri-drivers installed? Do you have any special boot flags? Please post the output of dmesg -t --level=alert,crit,err,warn and cat /proc/cmdline Oct 1, 2020 at 11:16
  • @ArtemS.Tashkinov I've updated the question with said details. I want to stress once more, this only happens with Chrome. Firefox, on the other hand, works just fine. Oct 2, 2020 at 12:16
  • AFAICS there's nothing serious in your logs which puzzles me. Please check your chrome://gpu/ (that's a URL you have to type in Chrome) for anything out of the ordinary. Lastly, please try disabling hardware acceleration in Chrome which is not optimal but may probably help you. Oct 2, 2020 at 15:09
  • I have the same problem with Ubuntu 20.04 using Wayland. Works fine under Xorg. Same problem with other chromium based browsers (tested Opera and Brave).
    – zelenyjan
    Oct 3, 2020 at 2:38
  • 1
    @zelenyjan Yeah, it must be a problem with Chromium, not my configuration. Oct 4, 2020 at 15:54

2 Answers 2

7

It is some sort of problem with wayland. A lot of people having same issue. I found this workaround. Just start chrome with additional parameters:

google-chrome --use-cmd-decoder=validating --use-gl=desktop
3
  • 2
    Just to add, that to make it permanent you sould go to /usr/share/applications and edit the file called google-chrome.desktop, then restart Wayland (it is enough to log out). It was driving me nuts, and, unbelievable, but this fixed the issue. This should be marked as the solution, @Boyan Kushlev
    – Sych
    Dec 15, 2020 at 19:49
  • I tried it, but it didn't help one bit. I've switched to Ubuntu instead. Jan 23, 2021 at 18:27
  • I have run into this Chrome lag issue since I got a new laptop, dock and monitors, and installed Fedora 38. I experience 2 second lag when scrolling, typing, clicking, and switching tabs. I normally have two Chrome profiles open, work and personal, where the work profile is a maximized window on my left monitor and the personal profile is a maximized window on my right monitor. Un-maximizing the window seems to resolve the lag. Or, leaving the windows maximized and running google-chrome --use-cmd-decoder=validating --use-gl=desktop also seems to resolve the issue. But I don't know why...
    – John Call
    Aug 28, 2023 at 16:52
0

I have the same problem on Fedora 32 with Chrome and Chromium. To add: The bug occurs when two profiles are open AND ONE of the two windows (or both) is maximized (not in full screen). By reducing the size of the windows, I can use both windows normally.

EDIT : Using "system title bar and borders", the problem is much much less present

4
  • 1
    Someone has downvoted this answer, but geez, as crazy as this sounds, I am having exactly the same issue, bought a brand new PC, a completely fresh install of Fedora 33, absolutely nothing installed except Chrome - having two profiles, and if I have any tabs maximized Chrome randomly becomes laggy, making it completely useless, while other software runs just fine. Sometimes it is faster to open Firefox and finish the stuff I was doing... Arhs, drives me nuts
    – Sych
    Dec 15, 2020 at 19:32
  • @Sych so they still haven't fixed it? I switched to Windows because of that issue. I'm just too coupled with Chrome to switch the browser instead. Dec 16, 2020 at 11:15
  • @BoyanKushlev, the fix from the solution that Thran has posted has fixed the problem for me INSTANTLY. See my comment below it, I describe how to add those parameters to be always present when you open Chrome in Gnome.
    – Sych
    Dec 17, 2020 at 11:35
  • The solution @thran gave didn't work for me... Try to create a shortcut and open it full screen. Then, open a full screen tab. Write in one window then switch on the other
    – avimimoun
    Dec 22, 2020 at 21:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .