0

My computer has Linux Mint 19.1 Tessa with R version 3.6.3. I am trying to do sudo apt-get update and I am having this error:

Err:21 https://cloud.r-project.org/bin/linux/ubuntu bionic Release             
  404  Not Found [IP: 2600:9000:2045:e400:6:c2d3:f940:93a1 443]
E: The repository 'https://cloud.r-project.org/bin/linux/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

Also, I would like to install appropriate drivers but I am also getting this error:

E:The repository 'https://cloud.r-project.org/bin/linux/ubuntu bionic Release' does not have a Release file.

Could someone help me? I remember that I had a problem upgrading R, but I am not sure what happened with Release. R now is working normally I think.

3

The R repository has separate bionic-cran35 and bionic-cran40 for R 3.5 and R 4.0 respectively. If you are using R version 3.6.3 on Linux Mint 19.1 Tessa, which is based on Ubuntu Bionic Beaver, you have to change the entry for R repository, which has to be in /etc/apt/sources.list or one of the .list files in /etc/apt/sources.list.d directory, to:

deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/

In your case, you need to replace bionic stable-cran35/ with bionic-cran35/ in your sources line for the R repository to make it as above.

You should be able to go in applications menu to Administration > Software Sources > Additional Repositories and edit your existing entry there.

Assuming that the entry is located in /etc/apt/sources.list.d/additional-repositories.list as you indicated, you can also edit it from command line with a text editor like nano like this:

sudo nano /etc/apt/sources.list.d/additional-repositories.list

Navigate to the entry with arrow keys, and correct it, press Ctrl+X, enter y, and hit Enter to save and exit editing.

Unlike editing an existing entry, when adding the entry for the first time, editing the file manually seems to be the only way. add-apt-repository and the graphical interface at Administration > Software Sources fail with "Malformed input, repository not added." In Debian, the package software-properties-common provides an abstraction for apt repositories, but in Linux Mint they replaced it with their own mintsources, which refuses to add such entry, but accepts editing it.

I assume that you already have the repository key installed. You need to install it if apt complains that the public key is not available:

Err:7 https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ InRelease                                               
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 51716619E084DAB9
…
W: GPG error: https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 51716619E084DAB9
E: The repository 'https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

For security, I advise to install keys only according to the official documentation. I provide here the command, which I tested, only for your convenience:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9

Tested on a fresh installation of Minux Mint 19.1 Tessa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.