1

I have a docker container running debian stretch and sssd 1.15.0.

The plan is to use it for SFTP purposes, and to authenticate users through LDAPS. The LDAP provider in this case is Azure Active Directory Domain Services (AADDS) which provides LDAPS functionality.

So far, i've been able to:

  • Successfully execute a simple bind
  • Mark port 636 as 'working'
  • Mark server as 'working'
  • Log directly onto the container with docker exec and perform a successful ldapsearch (returns 291 objects)

Sadly, I've been unable to ssh or sftp into the container as an LDAP virtual user.

Below is some relevant information including the debug output of both:

  • The startup of the container
  • The attempted login of a user

I have tried:

  • changing bind user format
  • using or not using a base_user OU
  • adding or not adding port 636 into the URI
  • testing (unsuccessfully) sssd authentication with getent (returns nothing)
  • testing a username with and without the full UPN (user vs user@domain)

Any assistance would be greatly appreciated

Seemingly, i don't appear to be able to add the code blocks required to show all the files, as stackexchange thinks this looks like spam for some reason, so I created a gist with all the details. If there is a better way for me to present this, please let me know.

https://gist.github.com/Lazarix/ed9792076680ead510220d6c8ebb8e6e

1

1 Answer 1

0

I believe i've solved this. Specifically within the context of connecting to AADDS as an ldap provider, I was missing the following option in sssd.conf, under the [domain/mydomain] section:

ldap_schema = AD

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .