0

I was trying to install ubuntu in an external disk, when i make the partitions, it says 'failed to format ext4'.

I tried with an older ubuntu version, and another distro and same error.

I disabled the secureboot.

The partitions i made are:

-efi 300 MB.

-/ 50 GB.

-Swap 8 GB.

Home rest.

I tried to make the same thing in another notebook 32 bits, and i could install linux and windows, so the problem is in 64 bits notebook. The disk is a notebook disk that i reused, with and SATA to USB 3.0 adapter. it has 320 GB, in gparted says 289 GB, and in the installation says 320 GB.

In the 32 bits notebook installation i made /boot partition instead efi. Does anyone knows what is the problem?

  • 1
    What says ‘failed to format ext4’? What are you using to partition the disk and set up file systems: GParted, fdisk and mkfs, something else? – user3840170 Sep 30 at 6:06
  • No, the error is in the installation, i make the partitions there. I tried to format the disk in gparted and says something like 'file directory not found' or something like that in /dev/sdb – lucas Sep 30 at 13:48
  • How is drive now partitioned? Or did you use it as live installer in hybrid mode and it needs partition table area erased, so drive can be seen correctly. help.ubuntu.com/community/mkusb#Re-use_the_pendrive Or have you not made drive as gpt? You can also use gparted but must change default partitioning first. Select gpt under device, advanced over msdos(MBR) default partitioning before starting. If still errors check that drive is still ok, with SmartStatus. – oldfred Sep 30 at 14:22
  • now that i could install ubuntu 32 bits have /boot partition, swap and /, i made that in the installer too, can the drive not be gpt compatible? in the 64 bits installer i make a gpt partitioning with efi, but i have not option to select msdos or gpt, must make it in gparted before installing? – lucas Sep 30 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.