0

A month or so ago my Arch system started hanging at "Reached target Graphical interface" and never launches Gnome Display Manager (GDM). I eventually found a workaround which was to simply switch to TTY 2 (ALT + F2) and then switch back to TTY 1 (ALT + F1) and that starts GDM fine. Here is a screenshot of the stuck/hung boot: screenshot of system hanging at "Reached target graphical interface"

I looked at this question, Arch Linux stuck at boot (reached target Graphical Interface), but am not using Virtualbox for this although I did have Virtualbox installed at the time I noticed the issue, and then uninstalled Virtualbox since then in my troubleshooting steps. I did try the answer in that question to install xorg-server, but it is already installed > https://unix.stackexchange.com/a/341293/27902.

I do have the service enabled. When I switch to TTY2, this is what systemctl status gdm.service says:

screenshot of output of "systemctl status gdm.service" in TTY2

Contents of /usr/lib/systemd/system/gdm.service:

[Unit]
Description=GNOME Display Manager

# replaces the getty
Conflicts=getty@tty1.service
After=getty@tty1.service

# replaces plymouth-quit since it quits plymouth on its own
Conflicts=
After=

# Needs all the dependencies of the services it's replacing
# pulled from getty@.service and
# (except for plymouth-quit-wait.service since it waits until
# plymouth is quit, which we do)
After=rc-local.service plymouth-start.service systemd-user-sessions.service

# GDM takes responsibility for stopping plymouth, so if it fails
# for any reason, make sure plymouth still stops
OnFailure=plymouth-quit.service

[Service]
ExecStart=/usr/bin/gdm
KillMode=mixed
Restart=always
IgnoreSIGPIPE=no
BusName=org.gnome.DisplayManager
StandardOutput=syslog
StandardError=inherit
EnvironmentFile=-/etc/locale.conf
ExecReload=/bin/kill -SIGHUP $MAINPID
KeyringMode=shared

[Install]
Alias=display-manager.service

Update: To clarify, I don't use Wayland but use X still.

4
  • Can you please share the contents of your gdm.service file? – spk Sep 28 '20 at 18:14
  • Thanks, just added the contents of my gdm.service file. – Elijah Lynn Sep 28 '20 at 20:11
  • I've been able to see the logs in TTY2 just before it hangs and was trying to copy/paste them here but seems like the systemd folks disabled persistent logging by default and it is proving to be challenging to enable persistent boot logs. I followed serverfault.com/a/809109/101677 and made some progress but the logs that I am seeing before hang are not persisting for some reason. I'll just add some screenshots I suppose. – Elijah Lynn Sep 28 '20 at 23:50
  • Crosslinking similar thread bbs.archlinux.org/viewtopic.php?id=256896 – Elijah Lynn Jan 6 at 3:31
1

K, the solution was this, credit to @cweagans for helping me out with this!

  1. systemctl disable gdm.service
  2. yay --remove gdm
  3. yay --sync --refresh gdm
  4. systemctl enable gdm.service
  5. reboot
  6. Works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.