13

I get what I believe is a file conflict error when I try to install docker/docker-ce on CentOS 8. This is also a follow up from How to install docker on CentOS?

So here's what I do to get the error:

dnf config-manager --add-repo=https://download.docker.com/linux/centos/docker-ce.repo

//Check for available versions and if its the latest just install it:
dnf list docker-ce
dnf install docker-ce

Error:
 Problem: problem with installed package podman-1.6.4-10.module_el8.2.0+305+5e198a41.x86_64
  - package podman-1.6.4-10.module_el8.2.0+305+5e198a41.x86_64 requires runc >= 1.0.0-57, but none of the providers can be installed
  - package containerd.io-1.3.7-3.1.el8.x86_64 conflicts with runc provided by runc-1.0.0-65.rc10.module_el8.2.0+305+5e198a41.x86_64
  - package containerd.io-1.3.7-3.1.el8.x86_64 obsoletes runc provided by runc-1.0.0-65.rc10.module_el8.2.0+305+5e198a41.x86_64
  - package docker-ce-3:19.03.13-3.el8.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
  - conflicting requests
  - package runc-1.0.0-64.rc10.module_el8.2.0+304+65a3c2ac.x86_64 is filtered out by modular filtering
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Sure I'll try --nobest as well:

sudo  dnf install docker-ce --nobest

Last metadata expiration check: 0:17:51 ago on Thu 24 Sep 2020 01:51:30 PM EDT.
Error:
 Problem: problem with installed package podman-1.6.4-10.module_el8.2.0+305+5e198a41.x86_64
  - package podman-1.6.4-10.module_el8.2.0+305+5e198a41.x86_64 requires runc >= 1.0.0-57, but none of the providers can be installed
  - package containerd.io-1.3.7-3.1.el8.x86_64 conflicts with runc provided by runc-1.0.0-65.rc10.module_el8.2.0+305+5e198a41.x86_64
  - package containerd.io-1.3.7-3.1.el8.x86_64 obsoletes runc provided by runc-1.0.0-65.rc10.module_el8.2.0+305+5e198a41.x86_64
  - package docker-ce-3:19.03.13-3.el8.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
  - conflicting requests
  - package runc-1.0.0-64.rc10.module_el8.2.0+304+65a3c2ac.x86_64 is filtered out by modular filtering
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)ting packages or '--skip-broken' to skip uninstallable packages)

If I try --allowerasing, sure that might work... but is it safe to erase these runc, podman and containerd files??? Will it work after that? It's so strange to be happening on such a major distro but I can't find a solid resolution.

1 Answer 1

25

The podman and buildah packages conflict with docker-ce. Remove them first:

yum erase podman buildah

And you can then install docker-ce:

yum install docker-ce

Or

dnf install docker-ce
2
  • 1
    Great I cant wait to try it. Do you know why buildah and podman were already installed? Theres not much installed on this system but I sure can't take any risks with it
    – bluesquare
    Sep 24, 2020 at 18:44
  • 1
    @estrando Podman is meant to replace Docker which isn't available in any of the CentOS 8 repos. That's why you have to add the Docker CE repo to install it. Podman is installed along with Buildah for installing container images as a build-in way rather than needing other software. Sep 24, 2020 at 19:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .