1

Sorry about the long explanation, i just want to know where i went wrong

i wanted to download kali on windows but microsoft store had some major bugs and after so many times of running different commands and doing others stuff i decide to go to https://store.rg-adguard.net/ which allowed me to download kali without using Microsoft store after i downloaded it from the site i tried to run the .Appxbundle but the install button turned grey and didn't do anything, so i cancelled it and typed Add-AppxPackage -Path "C:\Users\user\Downloads\KaliLinux.54290C8133FEE_1.5.0.0_neutral_~_ey8k8hqnwqnmg.AppxBundle" in powershell(Adminstrator) and then it installed but now there is a new problem, if i open the app from start menu, it waits for some time the it brings a popup saying The operation returned becuase the timeout period expired, then if i open kali.exe from C:\Program Files\WindowsApps\KaliLinux.54290C8133FEE_1.5.0.0_x64__ey8k8hqnwqnmg it opens cmd and shows

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x80070005
Error: 0x80070005 Access is denied.

Press any key to continue...

And after pressing any key it closes the window, an if i open cmd and type kali it returns The system cannot execute the specified program. , i have checked every where but nothing seems to be helping

I have also tried restarting LxssManager service

EDIT: if i run bash in command prompt it tells me

 Windows Subsystem for Linux has no installed distributions.
Distributions can be installed by visiting the Microsoft Store:
https://aka.ms/wslstore

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.