0

I need a separate browser instance that is configured to connect to a specific proxy that is used for accessing restricted network, but cannot be used for regular browsing, and also to keep the session accessing that network separate. So I've been using Firefox running in Docker (with another privileged container setting up the network for it).

It used to work just fine, but now it started causing lock-ups of the whole X always lasting a minute or two in which mouse pointer continues to move, but nothing else is redrawing. The lags appear to be triggered by showing a pop-up (menu, combo box etc.); might be some other display changes too. I've returned to the project after about half year and rebuilt the containers today, so I am not sure when exactly the problem might have started.

I am running it with -e DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix --init --ipc host. I've also tried adding -e _X11_NO_MITSHM=1 -e _MITSHM=0 and removing the --ipc host, which also works, but shows the same symptom. I've made no attempt to set up dbus connectivity.

The host system is Ubuntu 20.04, kept up-to-date, with KDE desktop. The container base is also Ubuntu 20.04.

There are unfortunately no errors on either the standard outpus/error of firefox, nor in .xsession-errors on the host. Any idea how to debug this?

0

I eventually worked around whatever the issue was by:

  • Starting xpra on an arbitrary, fixed high port (xpra start :99)
  • Setting the display to that port (-e DISPLAY=:99)
  • Keeping the mount and ipc (-v /tmp/.X11-unix:/tmp/.X11-unix --ipc host)
  • Attaching the xpra display (xpra attach :99)

The solution was inspired by this x11docker script where xpra is one of the options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.