0

My /etc/ssh/sshd_config set StrictHostKeyChecking = no then can not started:

StrictHostKeyChecking no

My sshd version is:

[root@localhost ~]# sshd --version
unknown option -- -
OpenSSH_7.4p1, OpenSSL 1.0.2k-fips  26 Jan 2017
usage: sshd [-46DdeiqTt] [-C connection_spec] [-c host_cert_file]
            [-E log_file] [-f config_file] [-g login_grace_time]
            [-h host_key_file] [-o option] [-p port] [-u len]

with the error:

Sep 23 04:32:47 localhost sshd: /etc/ssh/sshd_config: line 43: Bad configuration option: StrictHostKeyChecking
Sep 23 04:32:47 localhost sshd: /etc/ssh/sshd_config: terminating, 1 bad configuration options
Sep 23 04:32:47 localhost systemd: sshd.service: main process exited, code=exited, status=255/n/a
Sep 23 04:32:47 localhost systemd: Failed to start OpenSSH server daemon.
Sep 23 04:32:47 localhost systemd: Unit sshd.service entered failed state.
Sep 23 04:32:47 localhost systemd: sshd.service failed.

My Server is CentOS 7.7

1 Answer 1

0

this is an option from ssh_config (note there is no d)

man ssh_config

StrictHostKeyChecking If this flag is set to yes, ssh(1) will never automatically add host keys to the ~/.ssh/known_hosts

you check host key when you connect, not when receiving incomming connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.