0

I'm trying to change my i3 font on NixOS. I've installed the font Roboto via nix-env -iA nixos.roboto and event copied it to ~/.fonts just to cover my bases. Setting

font pango:Roboto 11

in my i3 config has no effect.

1 Answer 1

1

You'll want to use the fonts.fonts setting in your configuration.nix.

fonts.fonts = with pkgs; [ roboto ];

Then rebuild your system.

sudo nixos-rebuild switch

Then it will work how you'd expect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .