0

GPU-G is a linux alternative to CPU-Z on Windows (apparently) but I can't get it to run.

When I run python2 ./gpu-g I get the following error

You need to have PyGTK 2.10.0, GTK.Glade and GTK+ 2.10.0 or higher
installed in your system in order to run CPU-G.

I tried installing pip with the intention of trying to find those packages, as I could not find them with apt, but this gave me a python 3 version of pip.

Not sure what to try next?

1

CPU-G is a python 3 application.

The instructions to run it are published here: https://github.com/atareao/cpu-g

In short:

sudo apt install libgirepository1.0-dev gcc libcairo2-dev pkg-config python3-dev gir1.2-gtk-3.0
pip3 install pycairo PyGObject psutil dbus-python
git clone https://github.com/atareao/cpu-g.git
cd cpu-g/bin
python3 cpu-g
5
  • I edited your answer - did I get the correction correct? Sep 21 '20 at 22:09
  • It may need to be approved? Sep 21 '20 at 22:09
  • Regardless of edits - there is no file cpu-g in that directory Sep 21 '20 at 22:14
  • @user3728501 there definitely is: $ ls cpu-g/bin/cpu-g cpu-g/bin/cpu-g Sep 21 '20 at 22:41
  • Sorry I was looking in src not bin Sep 22 '20 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.