0

i have installed Ubuntu Server 20.04 64bit on a Raspberry Pi 3 image from https://ubuntu.com/download/raspberry-pi

all works well

then i installed the stock ubuntu desktop

sudo apt install ubuntu-desktop

after install completed i ran startx from the command line and ubuntu desktop fired up and all seemed to be working as expected.

i opened a command line and rebooted sudo reboot

the pi booted back up and entered the logon page where i clicked the user ubuntu and entered password then pressed enter.

that's as far as i get, the screen shows a few purple rectangles and a mouse pointer, the mouse pointer moves about but is rather useless.

my questions:

  1. how can i boot the pi to the server command line without auto starting the desktop giving me the change to remove it again or something.

  2. is this possibly something like driver compatibility that i may be able to work round or fix, the fact that it worked on the first boot tells me it must be fixable

i have tried to break out of the boot process and i end up at the command line as U-Boot> but this seems to be pre ubuntu server booting up and i don't no how to do anything useful from U-Boot>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.