1

suddenly, i3 stopped moving Inkscape to the workspace I assigned to it. I really cannot understand why it is doing this, because it was just working fine like two days ago.

I'll post the code I wrote in i3/config to move Inkscape to the ninth workspace and to move me as well to that workspace:

for_window [class="Inkscape"] move to workspace $ws9 workspace number $ws9

Moreover, this is the output of xprop used on the Inkscape window:

WM_CLASS(STRING) = "org.inkscape.Inkscape", "Inkscape"

If you need anything else, let me know.

(I checked that the name of the workspace is actually $ws9)

One thing I noticed is that it doesn't move only when I open it in workspaces where I have other windows; if it is in an empty workspace, it will be moved to the ninth one.

0

1 Answer 1

2

I had the same problem, and changing a few settings on Inkscape solved it for me.

Open Inkscape, go to Edit > Preferences. On the Preferences window, go to Interface > Windows. Then set the "Default window size" to Default, and "Saving window geometry (size and position)" to Don't save window geometry.

1
  • This makes sense. I just put OP's for_window line into my .config/i3/config and couldn't reproduce. So the problem wasn't related to the i3wm version or the command itself. It was interference from something else. Fortunately, you found it.
    – Stewart
    Jan 5, 2021 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .