I installed Arch i686 on a VirtualBox VM (I have an nvidia GT610). I ran the following command as root:

pacman -S nvidia 

After installation and rebooting, I ran

pacman -S xorg-server xorg-xinit xorg-server-utils xorg-twm xorg-xclock xterm



I got a fatal error saying No screens found. Any help as to what should I do ?


I was having this problem too while installing arch on Virtualbox. It was fixed after I did the following:

  1. Execute the following to install "mesa" and virtualbox support:

    pacman -S mesa xf86-video-vesa
    pacman -S virtualbox-guest-utils
  2. Open /etc/modules-load.d/virtualbox.conf with nano:

    nano /etc/modules-load.d/virtualbox.conf

    and write the following lines in the file:


    Press Ctrl+X , enter Y to confirm that you want to "save and exit", and when it asks for the filename hit Return without changing the name.

  3. Reboot by running:

  4. Install the following packages, if you have not already (I had them installed before, so I skipped this part):

    pacman -S xorg-twm xorg-xclock xterm
  5. Restart X:


I Installed Arch in virtualbox

A virtual machine running in vbox uses a emulated video card instead of your nvidia card.

Which means nvidia like driver is unnecessary.

Try X -configure first, which will generate a probed xorg config, but modern Xorg shouldn't need that at all. (If you have /etc/Xorg/xorg.conf, remove it)

  • This didn't help. X -configure returns No device to configure. COnfiguration failed. Server terminated with error (2).
    – c0dehunter
    Jun 20 '14 at 12:36
  • For 10 years people go around telling people that this shouldn't be needed. It's simply not true. Too often, it is needed. Please stop pretending it works. It would be nice if it did, and yes, it should. Should is irrelevant. Jan 29 '17 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.