I want to run a .msi file on Fedora 17. After installing Wine Windows Program Loader on my Linux machine, it failed to run the file. A check on /var/log/messages shows the following line:

Jan 11 17:32:26 some kernel: [15554.188474] type=1400 audit(1357983146.108:13): avc: denied { mmap_zero } for pid=4779 comm="wine-preloader" scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tclass=memprotect

An online forum has a suggestion to toggle a switch with:

setsebool -P mmap_low_allowed 1

I did that but it gave me an error:

libsepol.scope_copy_callback: entropyd: Duplicate declaration in module: type/attribute entropyd_var_run_t (No such file or directory). libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory). Could not change policy booleans

Next, I try setting SELinux to permissive mode with:

setenforce 0

After checking that SELinux is on permissive mode, I tried to run the file again, but to no avail. What could be causing this problem? And how do I solve it?

2 Answers 2


Set the boolean wine_mmap_zero_ignore to 1 with the command

$ sudo setsebool -P wine_mmap_zero_ignore 1

To enable new mode of SELinux you should restart your OS but before change your SELinux policy to permissive or disabled permanently via configuration file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .