0

I have ELK server, and sending Heartbeats to server. I added an monitor in monitors.d directory, added setup.dashboards.enabled: true line in heartbeat.yml file, but after restarting heartbeat service, service working 2-3 secand and then sending me this output message

Ping remote services for availability and log results to Elasticsearch or send to Logstash

I deleted my added line setup.dashboards.enabled: true and have not get that messages, hearthbeats worked, sent all beats to ELK server, but didn't send monitor's index

enter image description here

Can anybody help my to solve this issue

2
  • Can you clarify the problem a bit further? setup.dashboards.enabled specifies that the sample dashboards be loaded into Kibana. Do you have a problem with that? On the index side, the default index would be 'heartbeat-date' or 'heartbeat-version-date'. I can see that in your index pattern, so is there a problem there? – Haxiel Sep 19 '20 at 13:21
  • I'm trying to load dashboard where I can check my servers state (up,down), configured my Heartbeat to send metrics to Logstash, then I was learn about dashboard specific for heartbeat, where I can see my services status(up and down). So added an ssh.yml in the monitors.d directory , after that run my heartbeat, all worked but I have not seen heartbeat index in kibana, soI tried to add setup.dashboards.enabled: true line in heartbeat.yml, heartbeat worked 3 sec, and turned down, with this message Ping remote services for availability and log results to Elasticsearch or send to Logstash – khachikyan97 Sep 20 '20 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.