1

I have an odd issue that is actually solved but which I'm curious on if anyone knows the cause of.

I have a laptop (Lenovo ideapad 330) which came preinstalled with Windows 10. I have installed Ubuntu 20.04.1 LTS beside windows and can dual boot to either of them via grub.

When booting the laptop grub gives me 4 options:

  1. Ubuntu
  2. Advanced options for ubuntu
  3. Windows 10
  4. Bios (If i remember correctly)

Most times everything works as expected and I can boot into any of the options.

The issue:

Two times since I installed Ubuntu about a month ago the following has occurred: When I'm booting all 4 options above show up but I'm unable to choose 2 and 3. Arrow up and arrow down just jumps over option 2 and 3.

At this point if I boot into Ubuntu there is another issue. Some keys on the keyboard do not work while others do. I have not tested all keys to see which work. Most keys work but "c" and "spacebar" for example have no effect. Pressing them does nothing regardless of which application is open. The oddest part is the solution.

The solution:

If boot into Ubuntu, login and press the "Fn" key everything starts working as expected. All keys start working instantly in Ubuntu and I'm once again able to boot into Windows 10 and advanced options for Ubuntu.

So I have a solution to the issue but I'm extremely interested in if anyone knows why this happens as it seems very odd to me with an issue that relates to both the keyboard once booted in Ubuntu and not being able to boot into Windows and also that it happens intermittently. Any suggestions or thoughts?

I've tried googling the issue but have not found any matches that relate both to booting and keyboard and all options showing in grub without being able to select them.

0

I have a totally different laptop, and different OS setup, but the same issue occurred, and I was able to figure out why it happens. When you are shutting down the laptop, the Fn key gets stuck in the Pressed state. For this reason, when you try to boot, the computer remembers that the Fn key is in the Pressed state, and thinks that it is still pressed. Hence, pressing yields instead Fn+, in other words "Scroll to the very bottom", and pressing yields Fn+, or "Scroll to the very top". This is also the reason that some keys don't work -- the ones to which Fn+(key) has an associated action.

When you finally log in, you press the key, and Ubuntu sends an "Fn key released" signal, which releases the key, and allows you to proceed normally.

One other workaround that I've found, which I am not sure if will work on your setup, is that if I wish to press some key to which an Fn action is associated, then I can hold Fn while clicking that key, and that processes the key as if no Fn is held (i.e., the second press reverses the Pressed state of the Fn key). In other words, if I wish to boot into Windows, I would press Fn+, and that would do a regular scrolling down. However, Windows doesn't seem to be able to change the state of the Fn key, so I have to keep holding the Fn key down the entire time I work in Windows if I do this.

Please let me know if my second workaround works for you, I am curious.

4
  • try pressing Fn then press and release SHFT lock then release Fn – jsotola Sep 19 '20 at 23:45
  • Interesting to hear that someone else has the same issue at least. Since it hasn't reoccured yet I haven't been able to test if holding Fn in grub leads to being able to select windows. I guess the next question is why the laptop thinks the function key is pressed during shutdown? – Antti Stålnacke Sep 20 '20 at 14:03
  • @AnttiStålnacke Some bug with unix and the specific hardware used. For me, this also only happens intermittently, so I can't test jsotola's advice yet -- but, this only happens when I shut down in Unix. – Alex Sep 20 '20 at 14:13
  • Accepting this answer as it gives a bit more information on the issues. – Antti Stålnacke Sep 21 '20 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.