1

This is my environment :

X server : VCXsrv Windows
Window manager : XFCE/WSL
bash : 5.0.0(1)-release
Environment variable TERM : xterm

When I type a command longer than the width of xterm, the line scrolls horizontally instead of wrapping the line, like

<lllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll

Some online articles suggest following command :

bind 'set horizontal-scroll-mode off'

but it didn't fix the issue in my context.

What else can I try to troubleshoot ?

Update 1:

bash-5.0$ printf "%s\n" "$PS1"
\s-\v\$ 

Update 2:

/bin$ tput up
tput: unknown terminfo capability 'up'
22
  • Related questions are unix.stackexchange.com/q/525477/5132 and unix.stackexchange.com/q/529377/5132 .
    – JdeBP
    Commented Sep 19, 2020 at 10:12
  • @JdeBP, I looked at those two questions before I made the post. Apart from above bind command, what else can I try ?
    – Philippe
    Commented Sep 19, 2020 at 10:45
  • Have you checked the TERM variable? If it's wrong then off will not work. Commented Sep 19, 2020 at 10:51
  • @KamilMaciorowski As I said in post, TERM=xterm. I tried other values as well, like xterm-256color, or ansi, vt100, etc.
    – Philippe
    Commented Sep 19, 2020 at 10:58
  • OK, we know it's xterm; but does your machine know what xterm means? Commented Sep 19, 2020 at 11:06

2 Answers 2

1

Finally I got 5.0.18(1)-release source from github, compiled it which fixed the problem.

0

I'm running Linux Mint, and Bash 4.4.20 is installed by default.

I had manually compiled and installed Bash 5.0 and ran into the OP's rendering problem.

Upgrading to Bash 5.1 solved this rendering problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .