0

My Dell Vostro 3491 came with 1TB HDD and 256 SSD. Ubuntu was installed on the SSD and I can use the drive for storing and accessing files. But I am unable to access the HDD.

From the disk utilities, it seems my HDD is on standby (displaying ZZZ).

Using sudo fdisk -l I found my HDD is marked as /dev/sda and no partitions.

I tried mounting it using sudo /mount /dev/sda /media/HDD but getting an error mount: wrong fs type, bad option, bad superblock on /dev/sda, missing codepage or helper program, or other error.

What is the actual problem and how to solve it?

Do I need to create partition of /dev/sda ? Why?

  • 1
    Do you want to know how to mount a drive, where to find it in /dev and/or how to format it beforehand? – Fiximan Sep 14 '20 at 11:41
  • 1
    Have you tried creating and formatting partitions within /dev/sda (with GNOME Disk or GPartEd) before trying to mount them ? – breversa Sep 14 '20 at 15:27
1

Sorted this out. I had to format the HDD and then mount it as:

sudo mkdir /media/HDD
sudo mount /dev/sda /media/HDD
  • 1
    NO, you want partitions like sda1, not a drive like sda. You may not be able to remount as almost all tools expect partitions. and you want gpt partitions, not 35 year old MBR(msdos) partitions. You can also use gparted but must change default partitioning first. Select gpt under device, advanced over msdos(MBR) default partitioning before starting. gparted & fdisk instructions: help.ubuntu.com/community/InstallingANewHardDrive & help.ubuntu.com/community/HowtoPartition/… – oldfred Sep 15 '20 at 14:22
  • The command sudo lshw -C disk does not show up anything! – Arindam Ghosh Sep 15 '20 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.