0

I have installed Debian 10 on my laptop Dell Inspiron . But when booting first time into Debian, It directs me into the command-line interface, why?

I am sure, I have chosen Graphical Install during installation.

Is it related to the graphics of my laptop? My laptop has AMD Radeon R2 graphics and I am using the SDDM Display manager. It has AMD APU Dual Core E1 processor.

I have installed KDE plasma, LxDM, and Lxqt in the select and install software step during installation.

I have chosen SDDM as my Display manager between lightdm and sddm.

2 Answers 2

0

Finally found the solution for this problem, I think the sddm display manager is not working fine and thats's why I am booting into CLI. So, I just have to install another display manager which should work with my laptop hardware.

A brief explaination on this problem is here: Sddm is not starting but in theory everything is working!

First step: Update the /etc/apt/sources.list

sudo nano /etc/apt/sources.list

and add the following repositories(just copy and paste it):

deb http://deb.debian.org/debian buster-updates main
deb-src http://deb.debian.org/debian buster-updates main

# non-free firmwares
deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://deb.debian.org/debian buster-updates main contrib non-free
deb-src http://deb.debian.org/debian buster-updates main contrib non-free

deb http://security.debian.org/ buster/updates main contrib non-free
deb-src http://security.debian.org/ buster/updates main contrib non-free

save the file by Ctrl-O and Ctrl-M. Close the file by using Ctrl-X.

run sudo apt-get update and installed the lightdm display manager,you can install which you want

sudo apt-get install lightdm

Now we have to choose a display manager,so run the command

sudo dpkg-reconfigure lightdm

and choose the lightdm among the other options and reboot now. Problem solved.

0

The problem might be related to graphics-driver issues. I experienced the same with fresh debian buster kde plasma. In contrast to you, I use nvidia.

To solve this I had to add contrib and non-free to my source.list:

nano /etc/apt/source.list

deb http://ftp.uni-mainz.de/debian/ buster main non-free contrib
deb-src http://ftp.uni-mainz.de/debian/ buster main non-free contrib

deb http://security.debian.org/debian-security buster/updates main non-free contrib
deb-src http://security.debian.org/debian-security buster/updates main non-free contrib

# buster-updates, previously known as 'volatile'
deb http://ftp.uni-mainz.de/debian/ buster-updates main non-free contrib
deb-src http://ftp.uni-mainz.de/debian/ buster-updates main non-free contrib

The next thing was to update and install the linux firmware package:

sudo apt update
sudo apt install firmware-linux
sudo reboot

Right after this procedure I was able to launch kde plasma.


Unfortunately my desktop freezed several times with the stock kernel driver. After having installed the proprietary nvidia drivers, these issues went away. sudo apt install -y nvidia-detect && sudo nvidia-detect. Than install whatever driver nvidia-detect recommends to you or just do sudo apt install nvidia-driver

Tested with GeForce GT 710 and gtx970

1
  • you make this process very easy. Thank for your solution Commented Aug 27, 2021 at 13:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .