I see a very strange behaviour on some (not all) of my Linux machines. I am running Arch Linux with kernel 5.8.8-arch1-1

If I start the machine without grub loglevel parameter (or apply any from loglevel=0...6) boot stucks for ~90 seconds at "Loading initial ramdisk..." before continuing a very fast boot. Looking into the logs (journalctl -b, systemd-analyze blame etc.) shows no errors and tell a boot time of ~15 seconds - that is the time AFTER the delay. Bootlogs are identical to the machines which do not show the delay (identical Linux installation).

Then I tried parameter loglevel=7 in grub - and booting does no longer show the delay. Complete booting takes about 15 seconds - showing no issues. If I leave away grub loglevel parameter for kernel (or set it to any lower level than 7) booting shows big delay again. Is there any explanation for such a strange behaviour?

1 Answer 1


Poking into the dark I tried different grub kernel parameters I found on the web. "tsc=unstable" removes the delay for me at all selected loglevels. I do not understand why the delay depends on the selected loglevel but this fixes the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .