20

I am running VirtualBox 6.1 on Catalina 10.15.6 and when I start my Ubuntu 20.04 LTS VM it says "VirtualBox VM quit unexpectedly". How can I fix this?

The Apple report is below

Path:                  /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/MacOS/VirtualBoxVM
Identifier:            org.virtualbox.app.VirtualBoxVM
Version:               6.1.14 (6.1.14)
Code Type:             X86-64 (Native)
Parent Process:        VBoxSVC [2581]
User ID:               501

Date/Time:             2020-09-12 11:06:06.400 +0200
OS Version:            Mac OS X 10.15.6 (19G73)
Report Version:        12
Bridge OS Version:     4.6 (17P6065)
Anonymous UUID:        D239C6C6-47E5-4E96-B087-5A70B7918F9D


Time Awake Since Boot: 1100 seconds

System Integrity Protection: enabled

Crashed Thread:        34  Dispatch queue: com.apple.root.default-qos

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    Namespace TCC, Code 0x0

Thread 0:: Dispatch queue: com.apple.main-thread
34

Go to Settings > Audio and uncheck "Enable Audio". There seems to be a bug that crashes Ubuntu 20.04 LTS in VirtualBox when it attempts to check audio input permissions with CoreAudio.

00:00:32.681184 CoreAudio: macOS 10.14+ detected, checking audio input permissions

(then the system crashes...)

8
  • 4
    That worked like a charm. – Tarun Mohandas Sep 14 '20 at 4:37
  • 3
    yep, that was the secret sause. Cheers @brstream ! – mraxus Sep 17 '20 at 10:55
  • 3
    thank you, this saved it! – Dejan Jovanović Sep 18 '20 at 19:51
  • 3
    Thanks a bunch! This also solved the same error message that appeared when I tried to use virtual machine with the Debian 10.6.0 amd64 .iso. – datalowe Sep 27 '20 at 18:05
  • 2
    Thank you! worked for me! – apadana Sep 27 '20 at 22:19
10

For me. I tried two solutions (pick one):

  1. Starting virtualbox with sudoer works for me.

  2. Disable Audio also works settings->Audo--> uncheck Enable Audio.

enter image description here

1
3

All of the above is good info, but you have to dig down into the discussion a bit further if you're using bash.

I use bash, and the workaround from the discussion that worked for me was to start the gui with

    zsh -i -c virtualbox

Afterwards, I tried starting a vm via the commandline, e.g.

    vboxmanage startvm foobar

and that worked, too.

1
  • 1
    This one is the only one that worked for me. Doing so, virtualbox asked for microphone permissions, and did NOT crash! – GhostCat Oct 10 '20 at 5:19
0

Please try the below:

VM Crashing with Termination Reason: Namespace TCC, Code 0x0 (OSX/Mojava/Catalina)

Relevant bug thread: https://forums.virtualbox.org/viewtopic.php?f=8&t=97141

The Quick Fix:

  1. Open a Terminal window.
  2. Type 'virtualbox'.
  3. Hit enter.
  4. You should see Virtualbox open as usual (don't close the Terminal window, although you can minimize it).
  5. Now that VirtualBox is running inside the Terminal process, it has permission to ask for permission to use your camera/microphone.
  6. You can now launch your VM and should see a prompt asking you to allow it in the preferences.
  7. Just keep your terminal open for the remainder of your VirtualBox session.

A more effective solution should be forthcoming soon.

source

Not the answer you're looking for? Browse other questions tagged or ask your own question.