2

I like using libinput's on-button scrolling feature to make my trackball a scroll wheel when holding down BTN_BACK. The Arch Linux wiki describes how to configure this feature in Xorg. When I used sway, I was able to get the behaviour I wanted using the following configuration documented in sway-input(5):

input <identifier> {
  scroll_method on_button_down
  scroll_button BTN_BACK
}

I recently switched to GNOME on Wayland in order to try out a scrollable tiling window manager – PaperWM. But I can't figure out how to configure my scroll method in GNOME Shell. According to the Arch wiki, libinput's configurable options depend on the progress of your desktop environment's support for them, and I can't find anything relevant in GNOME Settings or GNOME Tweaks.

See also

2
  • 1
    I don't think Gnome currently provides the necessary setting. I remember, Gnome does provide more settings than you can change with GUI. To modify ones not presented by GUI, you have to use gsettings utility. So, when I execute gsettings list-recursively org.gnome.desktop.peripherals, I don't see a scroll-method option on my system, which likely means it's not provided at all. You will have to report a feature-request, not sure exactly where, but I think to gnome-shell. – Hi-Angel Sep 11 '20 at 9:43
  • Thank you for the comment! Interestingly, when I run that gsettings command I get org.gnome.desktop.peripherals.trackball scroll-wheel-emulation-button 0. Maybe this option is only available for trackballs? I'll keep investigating. – sjy Sep 12 '20 at 7:39
2

This option can be configured (for trackballs only) using the scroll-wheel-emulation-button setting. By default this is set to 0, meaning that no button will turn the trackball into a scroll wheel. I experimented with a few different mouse buttons and found that button 5 was the most convenient for scrolling on my trackball:

gsettings set org.gnome.desktop.peripherals.trackball scroll-wheel-emulation-button 5

This worked immediately, without needing to reboot or restart my GNOME session, in GNOME Shell 3.36. The feature was added in GNOME 3.16 (March 2015).

0

You can play with the gsettings in dconf-editor if you like a GUI. I used to have mine set to press and hold right click for scroll (button 3), but that doesn't seem to work for Wayland, the context menu tends to appear first so scrolling doesn't work. Changed to the Back button (button 8) and found it workable. Back still works on click, press and hold for scroll. As you say no need to restart Gnome to apply the settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.