0

I use Linux Mint, running Cinnamon as my DE.

I'm used to switching keyboard layouts using LAlt+LShift. I'm also used to switching windows between workspaces using LCtrl+LAlt+LShift+<direction>.

I used to have a configuration that allowed me to do both of those seamlessly - I do not remember having any issue with layouts changing without my will or with workspace hotkeys not working.

Unfortunately, a data loss incident has forced me to lose some configs - including this one.

Enabling the layout switching hotkeys in Keyboard Settings now makes me lose functionality I have with Ctrl+Alt+Shift.

How did I manage to set this up? I would like to do it again.

1
0

well, search for keyboard in Cinnamon menu. then the keyboard dialog will show up click on Layout. later on click on Options. there you will find Switching to another layout where you can choose key combinations to switch between layouts.

0

OP here, again.

First of all, this is now the first search result for my issue!

To all the people who stumble upon this - first of all, it's not only a me problem, it did work in Mint 18. Here's the bug people are tracking:

https://github.com/linuxmint/Cinnamon/issues/7664

TL;DR of the link above:

This is a long-standing bug in Xorg.

Ubuntu used to have a patch for it - but doesn't anymore, ever since they switched from the Unity/Lomiri desktop environment and lost the need to keep it around (the bug seems not to affect GNOME shell).

Mint pulls from Ubuntu, so now it is broken for them as well.

To mitigate this:

sudo add-apt-repository ppa:nrbrtx/xorg-hotkeys
sudo apt-get update
sudo apt-get dist-upgrade
1
  • I've added the commands to do the workaround. Hopefully this will constitute a better answer. Sep 16 '20 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.