2

I'm running Debian (10.5) with the 5.7.0 kernel and Gnome. I've previously asked this question here, without luck: http://forums.debian.net/viewtopic.php?f=7&t=147161

Here's the situation: I have a Samson XDP2 wireless Lavalier microphone (http://www.samsontech.com/samson/products/wireless-systems/xpd-series/xpd2lav/). It consists of a transmitter pack, to which a lavalier microphone is connected, and a USB receiver, which also has a headset output.

If I listen in on the receiver using the headset port the sound is fine -- strong and clear.

However, the sound that I receive in linux is very, very weak.

By default Pulseaudio allows you to boost via GUI to 153% (norm*2). Using pactl set-source-volume in the terminal I can boost the input enough that I get a good signal (ca 270% -- no clipping, and the dynamic range sounds fine to me).

I will have to go in and do this manually each time, and if I touch the slider in pavucontrol or gnome-settings then I lose the boost.

My questions are:

Can I set the default boost permanently (to 270%) for this device via a pulseaudio configuration file, so that it applies every time I plug in the device?

AND/OR

Can I change the allowable volume range in the GUI (pavucontrol or gnome-settings) so that I can use the slider up to e.g. 300%?

What I've done: I've fiddled with the pulseaudio source code -- I changed volume.h from PA_VOLUME_UI_MAX (pa_sw_volume_from_dB(+11.0)) to PA_VOLUME_UI_MAX (pa_sw_volume_from_dB(+35.0))

but it changed nothing. I've also changed org/gnome/desktop/sound/allow-volume-above-100-percent to true via dconf. The sliders are limited to 153%. I've even done the window-y thing and rebooted for the first time in months.

So what can I do to make a solution as hands-off as possible? I use the mic for lectures and there are enough distractions (students asking questions, cleaning up after the previous lecturer, setting up cameras and computer) before a lecture that it's easy to forget to adjust the input volume.

Cheers in advance.

1
  • I have the same issue just now I was trying to solve it and this was one of the first search hit. I did not tested yet and I'm not sure I will be able to do today, but is seems that "set-source-volume" can be used also in /etc/pulse/default.pa. So something like: set-source-volume 1 300000 could work. Since I did not tested yet I don't know if it works and you can still use volume slider without losing the volume.
    – tuxfan77
    Sep 9 '20 at 20:37
0

I'm an Arch user but the issue you have faced is common to any distribution and seems occur depending on the hardware support , drivers side. There are workaround and maybe with time it will come to be fixed by some one skilled enough to code few lines. There are two approach to this case , one easy one less:

1) Via App (the easy one): The 150% of override incoming volume is not enough for many. For what I discovered there is no boost in any pavucontrol , alsamixer , ecc that can make the job of rise the Mic rec sound level at decent numbers. But you can use PulseEffects ! https://github.com/wwmm/pulseeffects enter image description here enter image description here Is a very good equalizer that allow to control the boost channel for input and output. If you are a PulseAudio user you have to install PulseEffect-Legacy-git that still use the PulseAudio core. The last version of this equalizer use PipeWire and you should substitute PulseAudio with Pipewire for make it work. In the program:

  • icon top left playback and microphone (each for sum the gain)
  • Limiter setting
  • move the input to 36db. Then you can fine the right combo between the PulseAudio override and the equalizer. I-m usin it on a Asus Xonar AE with a cheap Mic and the result is very good , not rustling at all.

2) The coder approach: ALSA offer the "softvol" solution. This one should be the more clean at all. I would like to apply it but I should learn too many stuffs...it need time.

https://alsa.opensrc.org/How_to_use_softvol_to_control_the_master_volume

In ~/.asoundrc or in /etc/asound.conf we can make the mods. "aplay -L" will show us the devices to use and redirect. ect ect in the link. We can create a redirect control that apply the gain we want to the input source (personal "db" range). So with just a permanent control we can use the Mic as we want. This guy made something similar for the SPi:

https://raspberrypi.stackexchange.com/questions/89966/how-do-i-increase-the-input-volume-of-a-microphone-connected-to-pi-its-using-th

This second solution could be integrated in ALSA libraries and make it useful for any distro.

-(OT) Tip: For make a specific sound level a startup: edit 6-4-2021 Seems that now pulseaudio remember the last volume settled. I had just to make a script for load pulse audio at startup .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.