0

I tried to upgrade Debian 8 to 10 by first upgrading it to version 9 and then to 10. I did this by changing /etc/apt/sources.list, running apt-get update, apt-get upgrade and apt-get dist-upgrade. The upgrade from 8 to 9 went well without issues. Then I changed sources.list to point to the current stable repositories, and upgraded. Like previously, it upgraded with no issues, but after it completed, I found it unable to resolve hostnames for any online resource (apt update says Temporary failure resolving deb.debian.org, ping google.com says Temporary failure in name resolution). I tried adding nameserver 8.8.8.8 to /etc/resolv.conf, but that didn't fix my issue.

I would also like to point out that I am running Debian on an old Asus ME173X Android 4.2.2 (armhf) tablet with chroot in a terminal emulator.

How to fix name resolution?

  • 2
    What happens when you try ping 8.8.8.8? This sounds like a networking problem - has the tablet reconnected to your wifi (or ethernet)? – icarus Sep 8 at 14:57
  • 64 bytes from 8.8.8.8: icmp_seq=1 ttl=119 time=30.1ms – lorinet3 Sep 9 at 9:13
  • OK so not obviously a network problem. Next guess, /etc/resolv.conf has CR characters at the end of the lines. Possibly use mv to save the current one if you think you might want to look at it later and then use ( echo nameserver 1.1.1.1 ; echo nameserver 9.9.9.9 ; ) > /etc/resolv.conf to set a different pair of nameservers just in case. – icarus Sep 9 at 16:07
  • This question has an answer here (icarus is right i guess) – karlsebal Oct 10 at 15:21
  • 2
    Does this answer your question? Temporary failure in name resolution after upgrade to Debian Buster – karlsebal Oct 10 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.