76

I recently installed ubuntu 20.04 and bluetooth seemed to work out-of-the-box. Yesterday, it stopped working with no known reason.

I can turn it ON but the settings still show it to be OFF.enter image description here

I tried the following:

$ sudo -i
$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

and on running bluetoothctl,

Agent registered
[bluetooth]# power off
No default controller available
[bluetooth]# power on
No default controller available
[bluetooth]# exit

What could be the problem and how to tackle it ?

8
  • 2
    Try sudo systemctl start bluetooth
    – Rayleigh
    Commented Sep 6, 2020 at 9:02
  • 4
    @Rayleigh It does nothing :/
    – Pe Dro
    Commented Sep 6, 2020 at 11:34
  • 1
    Don't have enough reputation to post an answer, but this helped me: sudo rmmod btusb; sudo modprobe btusb Found here: techstoriesindia.blogspot.com/2020/05/…
    – S. Kaczor
    Commented Nov 7, 2021 at 0:12
  • 1
    Happens to me whenever I turn BT off, from then on there is nothing you can do to turn it back on and you have to restart the computer. There does not seem to be any solution here except the cold boot. Commented Feb 3, 2022 at 0:47
  • 4
    (Not enough reputation to make this into an answer) Try this: sudo modprobe -r btusb; sudo modprobe -r btintel; sudo modprobe btusb; sudo modprobe btintel. Found the answer in dev-qa.com/1968645/….
    – mjkvaak
    Commented Jun 22, 2022 at 11:44

10 Answers 10

44

It's a bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1859592

Cold boot as in powering off from PC's source button (taking electricity off the mother board) worked for me. Just shutting down and having the motherboard LEDs on didn't work.

4
  • 3
    I just wanted to point out, this is not an Ubuntu problem. I'm facing this in Manjaro. And it's not even a desktop manager problem. I've had this in Gnome as well as KDE. This is a kernel problem (or driver, not sure). For the record, I'm using kernel 5.14.7-2.
    – Mehran
    Commented Oct 1, 2021 at 1:01
  • I tried to reboot but didn't work. The trick was to unplug it, it is really weird! Commented May 31, 2022 at 13:17
  • What to do on a laptop if I can't take the battery out?
    – Miladiouss
    Commented Sep 5, 2023 at 19:08
  • Shutting down the PC and removing the power plug worked. Simply rebooting didn't work. Neither did rebooting into Windows. Glad I finally found this. Was about to order a new motherboard.
    – domo
    Commented Feb 26 at 20:16
36

I tried various hacks (all at once) and did a restart but I am not sure which led to the bluetooth working right.

I ran

sudo apt-get update
sudo apt upgrade
sudo systemctl start bluetooth
sudo rfkill unblock bluetooth   # rfkill also requires sudo

And after the restart, it worked :?

1
  • For me the rfkill command did it (no restart). Commented Nov 15, 2023 at 23:26
17

I just experienced the exact same issue, always off in Gnome and no controller found. What do you see if you type the following in a terminal ?

dmesg | grep -i bluetooth

I had this log:

Bluetooth: hci0: Reading Intel version information failed (-110)

To resolve the problem, all I had to do was to perform a cold boot of my laptop.

Cf. comments in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1859592

1
  • I had the same message in the log. Having my laptop shut down for several hours with A/C adapter connected did not fix the problem. However shutting down, unplugging A/C for a few seconds and then rebooting fixed it.
    – yankee
    Commented Apr 9, 2023 at 6:30
3

This has happened to me before when I'd accidentally pressed the bluetooth on/off button on the laptop. (fn-F10 on my Thinkpad)

0
2

try these commands .. it worked for me

sudo apt install --reinstall bluez gnome-bluetooth
indicator-bluetooth pulseaduio-module-bluetooth
sudo systemctl enable bluetooth
pulseaudio --start
sudo killall pulseaudio
pulseaudio --start
0

I had the same issue after installing a Windows 10 VM in a gnome-box and giving it access to bluetooth. After doing a clean shutdown of the WIN10 VM, bluetooth became available again on ubuntu.

1
  • 2
    I don't see how this relates to the question. Your issue was most likely caused by the VM taking over bluetooth, then releasing it when it wasn't needed. Commented Dec 13, 2020 at 6:29
0

Worked for me:

sudo apt install linux-generic-hwe-18.04

Or you can use:

sudo apt install linux-generic-hwe-20.04.

#it would install linux kernel version 5.13.0-25-generic.

Then restart the PC.

0

On my Ubuntu 20.04 the service daemon was using an invalid program. Check the config file below and try to fix the "ExecStart" entry. Make sure to be root (sudo -i).

/lib/systemd/system/bluetooth.service

#ExecStart=/usr/lib/bluetooth/bpavucontrolluetoothd # old entry ExecStart=/usr/lib/bluetooth/bluetoothd # new entry

After fixing it, bring service up: "systemctl start bluetooth" Them, try to enable the bluethooth and pair it via Seetings panel.

1
  • Welcome here. From the highest voted answer, I understand that the problem in this very question was related to a bug. Therefore I doubt that some erroneous ExecStart (which looks like a typo problem) would have solved it. But you are correct in case of problem in general, verifying that the ExecStart field matches the correct path to the daemon is among the things to do.
    – MC68020
    Commented Apr 6 at 8:05
0

If you are facing this issue , here are quick fixes , will surely work :)

sudo su
apt install aptitude
aptitude install bluetooth
/etc/init.d/bluetooth start

And here you go <:)>

no need to restart

1
  • 1
    (1) Use sudo -i instead of sudo su. (2) Can you explain why it would be necessary to install Bluetooth software when it had been working the day before? Commented May 1 at 16:33
-1

I experienced a similar problem in my case I turned of the Bluetooth module from laptop mode tools, Restarted, and never had any problems regarding Bluetooth since then. Apparently, the LMT Bluetooth module is designed to save power by turning off Bluetooth and it really won't kill much of the battery by disabling it.

1
  • 2
    how did you do that?
    – Sayan Dey
    Commented May 30, 2021 at 7:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .