0

I would've went with just using the ones provided by Kali but they are giving me an input not supported which I have no idea what caused(tried logging in with an RDP and setting xrandr to 1024x768 cause I thought maybe it was set way higher than it should but that didn't help at all so I decided to install the official nvidia drivers. I can't seem to find anything out there that actually works, Kali's docs provide a guide but it only works if it supports cuda which my driver don't, since it's a legacy driver. I tried going the old way of just downloading the run file and installing it manually I I blocked the nouveau, stopped lightdm switched to tty1 but it gave an error because Kernel source tree isn't found I tried just installing the nvidia driver using the simple 'apt-get install nvidia-driver' and it shows as installed just not in use I thought about disabling the other driver but well there's just too many for that here should be all relevant information I guess after disabling the nouveau and installing nvidia-driver

uname -r
5.7.0-kali1-amd64

lspci -v | grep driver
        Kernel driver in use: pcieport
        Kernel driver in use: e1000e
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: snd_hda_intel
        Kernel driver in use: pcieport
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: lpc_ich
        Kernel driver in use: ahci
        Kernel driver in use: i801_smbus

lspci -s 01:00 -v
01:00.0 VGA compatible controller: NVIDIA Corporation G96CGL [Quadro FX 580] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: NVIDIA Corporation G96CGL [Quadro FX 580]
        Flags: fast devsel, IRQ 11, IOMMU group 1
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=512M]
        Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
        I/O ports at dc80 [size=128]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel modules: nvidia
5
  • 1
    Nvidia drivers are really terrible to deal with under Linux, and it has been that way for almost as long as either Nvidia or Linux has existed. The history is long and well documented. I used to have to recompile the kernel to get X to work at all. Get a better graphics card.
    – Z4-tier
    Sep 5, 2020 at 0:06
  • I do have a different pc which is what I usually use and never had any issues with that but I do need two devices and affording another one isn't really an option for me atm
    – bido whab
    Sep 5, 2020 at 10:00
  • How did you install the nvidia drivers? Debian-based systems including kali include some packaged proprietary nvidia drivers. These are configured to work well with debian-based systems. If you ran scripts directly from Nvidia, then you'll probably run into problems. See DontBreakDebian for details.
    – Stewart
    Sep 6, 2020 at 18:49
  • 1
    I see you've tried apt install nvidia-driver, but you're running a 580. With a pre-600 series, an older driver might work better. Try apt install nvidia-legacy-390xx-driver instead. Debian's wiki has some details
    – Stewart
    Sep 6, 2020 at 18:57
  • @Stewart well I only tried all that in the first place because whatever Linux distro I ever try gives me a cannot display output error on my monitor, I thought it was a resolution error so I tried so hard to get xrandr to work properly but with further testing, everything seemed pretty fine
    – bido whab
    Sep 15, 2020 at 0:05

2 Answers 2

1

For me, with a graphic card Geforce gt210 on Kali Linux 2020.4 release, the solution was pretty much the same thing that @Stweart is advising. Just needed to install the right version of Nvidia driver for my graphic card(which can be found on the Nvidia website) and mine was 340.76. After that, I just run in the terminal this command:

sudo apt install nvidia-legacy-340xx-driver
sudo apt install nvidia-xconfig
sudo nvidia-xconfig
sudo reboot

And that's it everything working fine.

0

Late answer but I have managed to fix the issue actually, I am still not sure what was wrong exactly but once I switched to DVI cable instead of VGA with a converter it worked just fine, no more resolution error

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.