3

I don't remember how the program behaved on Windows, but on Linux pressing Enter for a feed item (with a Website field) always opens the Thunderbird's internal browser, while clicking the URL launches my default browser (Firefox).

This damages my keyboard-centric workflow.

In the Thunderbird's config editor I've set both network.protocol-handler.warn-external.http and network.protocol-handler.warn-external.https to true and associated Firefox in the 'attachment' options (reference). This made no difference I was able to notice.

2
  • 1
    support.mozilla.org/en-US/kb/how-subscribe-news-feeds-and-blogs, in the "Advanced Tips" section, mentions rss.show.content-base and rss.message.loadWebPageOnSelect. It's been ages since I used TB for RSS but my notes say these entries helped me. I cannot be 100% sure what you need is what I had at that time, but it can't hurt to try...
    – user339730
    Sep 8, 2020 at 11:27
  • @sitaram: rss.show.content-base to 3 alone appears to have started loading websites in my default browser. While this doesn't disable the TB's web browser (which I'd prefer for security reasons) and the changelog for instance loads there, I consider the comment as an answer.
    – user598527
    Sep 8, 2020 at 14:46

1 Answer 1

2

In the Config Editor, set the rss.show.content-base property to 3.

According to the Mozilla Support page, the different values correspond to:

0 - open web page in new window
1 - open summary in new window
2 - toggle load summary and web page in message pane
3 - load web page in browser

Also, Thunderbird supports an additional action on the selection of a feed message with the setting rss.message.loadWebPageOnSelect:

0 - no action
1 - load web page in default browser
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .