0

I have a problem where my second monitor shows up in settings and is properly identified, but nothing appears on the screen and the monitor says there's no input signal. Settings even shows the second monitor, brand and model number, resolution, and allows me to place it correctly in relation to the other. I opened an app after connecting the HDMP monitor, and KDE opened it on that monitor and I had to blindly move it to the one that works.

I'm running on a 2010 Mac Pro 5,1 which has been sitting turned off for some time. Today I reconnected it, logged in, allowed Neon to update and reboot, and now I'm running KDE Neon 5.19 and the OS is updated to 20.04. The primary monitor is a 30" Apple Cinema Display connected to the dual-link DVI port and the second monitor is an Asus HDMI connected via a Disaplayport to HDMI adapter - and this arrangement worked before with Neon.

Note that the Asus monitor was working fine this morning connected to my MacBook Pro and the same HDMI cable happily displaying Will Smith in all his blueness.

$ sudo lshw -c video
    *-display                 
       description: VGA compatible controller
       product: Juniper XT [Radeon HD 5770]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:42 memory:80000000-9fffffff memory:a0400000-a041ffff ioport:3000(size=256) memory:a0420000-a043ffff
$ glxinfo -B 
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD JUNIPER (DRM 2.50.0 / 5.4.0-42-generic, LLVM 10.0.0) (0x68b8)
    Version: 20.0.8
    Accelerated: yes
    Video memory: 1024MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 1023 MB, largest block: 1023 MB
    VBO free aux. memory - total: 1021 MB, largest block: 1021 MB
    Texture free memory - total: 1023 MB, largest block: 1023 MB
    Texture free aux. memory - total: 1021 MB, largest block: 1021 MB
    Renderbuffer free memory - total: 1023 MB, largest block: 1023 MB
    Renderbuffer free aux. memory - total: 1021 MB, largest block: 1021 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 1024 MB
    Total available memory: 2045 MB
    Currently available dedicated video memory: 1023 MB
OpenGL vendor string: X.Org
OpenGL renderer string: AMD JUNIPER (DRM 2.50.0 / 5.4.0-42-generic, LLVM 10.0.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.0.8
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 20.0.8
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
$ lsmod | grep radeon
radeon               1474560  39
i2c_algo_bit           16384  1 radeon
ttm                   106496  1 radeon
drm_kms_helper        184320  1 radeon
drm                   491520  12 drm_kms_helper,radeon,ttm
$ dmesg | grep -i radeon
[    1.432044] [drm] radeon kernel modesetting enabled.
[    1.432153] radeon 0000:05:00.0: remove_conflicting_pci_framebuffers: bar 0: 0x80000000 -> 0x9fffffff
[    1.432155] radeon 0000:05:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xa0400000 -> 0xa041ffff
[    1.432157] fb0: switching to radeondrmfb from EFI VGA
[    1.432230] radeon 0000:05:00.0: vgaarb: deactivate vga console
[    1.704374] radeon 0000:05:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[    1.704375] radeon 0000:05:00.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
[    1.704649] [drm] radeon: 1024M of VRAM memory ready
[    1.704650] [drm] radeon: 1024M of GTT memory ready.
[    1.735953] [drm] radeon: dpm initialized
[    1.752345] radeon 0000:05:00.0: WB enabled
[    1.752347] radeon 0000:05:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0x(____ptrval____)
[    1.752348] radeon 0000:05:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0x(____ptrval____)
[    1.752655] radeon 0000:05:00.0: fence driver on ring 5 use gpu addr 0x000000000005c418 and cpu addr 0x(____ptrval____)
[    1.752658] radeon 0000:05:00.0: radeon: MSI limited to 32-bit
[    1.752694] radeon 0000:05:00.0: radeon: using MSI.
[    1.752717] [drm] radeon: irq initialized.
[    2.619150] [drm] Radeon Display Connectors
[    2.801166] fbcon: radeondrmfb (fb0) is primary device
[    2.801170] radeon 0000:05:00.0: fb0: radeondrmfb frame buffer device
[    2.812433] [drm] Initialized radeon 2.50.0 20080528 for 0000:05:00.0 on minor 0
[    3.221568] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[    3.221590] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[    6.773595] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[    6.773674] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[    6.801333] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[    6.801353] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[   30.881740] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[   30.881761] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 1417.285859] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[ 1417.285878] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 1453.047925] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[ 1453.047946] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 1453.075339] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[ 1453.075357] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 1522.657832] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[ 1522.657854] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 2923.507898] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[ 2923.507918] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 2971.109724] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[ 2971.109761] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 2994.406908] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery reached max voltage
[ 2994.406946] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy