1

The OS is Pop!OS 20.04, a close derivative of Ubuntu (but I was told to post the question here). I don't think my question is pop or ubuntu specific.

I have masked these two services, and rebooted. Yet, they still show as enabled.

tim@indigo:~$ systemctl list-unit-files | grep speech speech-dispatcher.service masked enabled
speech-dispatcherd.service masked enabled
tim@indigo:~$

But despite that, the service is running with systemd as its parent, although it is running under my user. That is, the parent process (pid 2376) is

/lib/systemd/systemd --user

Is there a user-specific way of masking services?

Because systemd is the parent, I assume that it is starting as a service. How can something by masked and enabled (after a reboot)?

I don't know what is starting it. I don't want to remove the package which installed the service since it has some dependencies I don't want to remove. I think systemctl should let me stop this, but so far I obviously haven't worked that out.

 ps -aef | grep speech
tim        16850    2376  0 Aug31 ?        00:00:00 /usr/lib/speech-dispatcher-modules/sd_dummy /etc/speech-dispatcher/modules/dummy.conf
tim        16853    2376  0 Aug31 ?        00:00:00 /usr/lib/speech-dispatcher-modules/sd_espeak-ng /etc/speech-dispatcher/modules/espeak-ng.conf
tim        16859    2376  0 Aug31 ?        00:00:00 /usr/lib/speech-dispatcher-modules/sd_generic /etc/speech-dispatcher/modules/mary-generic.conf
tim        16862    2376  0 Aug31 ?        00:00:00 /usr/bin/speech-dispatcher --spawn --communication-method unix_socket --socket-path /run/user/1000/speech-dispatcher/speechd.sock

Update: Firefox is starting it.

├─gnome-launched-firefox.desktop-16219.scope 
           │ ├─16219 /usr/lib/firefox/firefox -new-window
           │ ├─16286 /usr/lib/firefox/firefox -contentproc -parentBuildID 20200829200810 -prefsLen 1 -prefMapSize 236679 -appdir /usr/lib/firefox/browser 16219 true socket
           │ ├─16516 /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 1416 -prefMapSize 236679 -noScache -parentBuildID 20200829200810 -appdir /usr/lib/firefox/browser 16219 true tab
           │ ├─16526 /usr/lib/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 1416 -prefMapSize 236679 -noScache -parentBuildID 20200829200810 -appdir /usr/lib/firefox/browser 16219 true tab
           │ ├─16585 /usr/lib/firefox/firefox -contentproc -childID 4 -isForBrowser -prefsLen 1600 -prefMapSize 236679 -parentBuildID 20200829200810 -appdir /usr/lib/firefox/browser 16219 true tab
           │ ├─16646 /usr/lib/firefox/firefox -contentproc -childID 5 -isForBrowser -prefsLen 7644 -prefMapSize 236679 -parentBuildID 20200829200810 -appdir /usr/lib/firefox/browser 16219 true tab
           │ ├─16708 /usr/lib/firefox/firefox -contentproc -childID 6 -isForBrowser -prefsLen 7779 -prefMapSize 236679 -noScache -parentBuildID 20200829200810 -appdir /usr/lib/firefox/browser 16219 true tab
           │ ├─16751 /usr/bin/python3 /usr/bin/chrome-gnome-shell /usr/lib/mozilla/native-messaging-hosts/org.gnome.chrome_gnome_shell.json [email protected]
           │ ├─16850 /usr/lib/speech-dispatcher-modules/sd_dummy /etc/speech-dispatcher/modules/dummy.conf
           │ ├─16853 /usr/lib/speech-dispatcher-modules/sd_espeak-ng /etc/speech-dispatcher/modules/espeak-ng.conf
           │ ├─16859 /usr/lib/speech-dispatcher-modules/sd_generic /etc/speech-dispatcher/modules/mary-generic.conf
           │ ├─16862 /usr/bin/speech-dispatcher --spawn --communication-method unix_socket --socket-path /run/user/1000/speech-dispatcher/speechd.sock

Update 2: I think this only looks like systemd. I will try this Firefox config setting:

reader.parse-on-load.enabled false
media.webspeech.synth.enabled false

tip from:

https://www.reddit.com/r/firefox/comments/7n5vn6/linux_firefox_and_speechdispatcher_are_making/

1 Answer 1

1

Solution: The firefox settings mentioned here

https://www.reddit.com/r/firefox/comments/7n5vn6/linux_firefox_and_speechdispatcher_are_making/

 reader.parse-on-load.enabled false
 media.webspeech.synth.enabled false

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .