0

I had a failing 3 TB hard drive that I was using to backup games on Xbox One. I just got a new 3 TB hard drive to replace it. I tried to copy over the files through the Xbox One but it failed probably because the old drive lost connection with the console or vice versa. I decided to try using backtrack to access the two drives and copy the files and then found out that backtrack changed over to Kali a long time ago XD. I swear I'm not old ;) Anyway, I just downloaded the latest stable version of Kali and I'm booting it live from a thumb drive.

Now, the drives did not pop up on the desktop so I went to see about mounting them manually. sudo /sbin/fdisk -l shows both drives are recognised so I ran mkdir and then ran mount but I got the error: wrong FS type, bad option, bad superblock, missing codepage or helper program, or other error

lsblk output:

lsblk output

ADDITIONAL:

Today I stumbled across this article:

https://withinrafael.com/2014/06/25/taking-a-peek-at-xbox-one-formatted-disks-in-windows/

It basically says that the Xbox One formatted the partition table on these drives so that they wouldn't be able to be used on a PC. It says that the info that is supposed to be at the beginning of the drive is all 0's. The article does however go into some detail that may be useful in figuring out a work-around. Any ideas?

PS: This is my very first post and I am currently struggling with this dilemma. Please stop down-voting my post and suggest how I can make it better instead. I'm trying.

1
0

Hm... maybe you need to specify the filesystem type manually? with mount -t <filesystem-type> <block-device> <mount-point>. Tell me if it works.

Regards.

P.S: If it doesn't please be more detailed (attach screenshot next time) so we can try to help you.

1
  • It did not work but I think I at least found out why. I still don't know how to fix it yet though. Please check my post update and thank you for helping.
    – Err
    Aug 28 '20 at 15:35
0

It seems that filesystem support (for example your disk could be formatted using NTFS or exFAT) is missing from the live Kali system. I think the needed packages for support can be installed, but will not remain after reboot, due to live system.

Can you send the result of
sudo lsblk -o name,fstype,size,mountpoint,model,vendor


Apparently the article you mentioned is correct, as we see from the lsblk output, no file system seems to be present on sdb, the Seagate disk.

One way would be to follow the article, hex-edit the source disk, view files. Then format the destination disk using NTFS, copy the files from source, and then hex-edit the destination disk to be as Xbox likes it.

Another way would be to try to clone the original disk in a file system agnostic way, sector by sector. Having the same size helps. The problem using this method is that possible problems on source disk will be also replicated - you didn't describe the failing problems of Seagate. Nevertheless, you can try clonezilla, clonezilla for this task. It's free and open source and can copy sector by sector, doing a full clone of your source disk. Don't be intimidated by Clonezilla's text interface, it's really easy to use. Boot from Clonezilla boot cd or usb, locate the source and destination disk (be careful on this, you wouldn't want to make a mistake!) and let it roll; the default settings are sensible.

4
  • It wouldn't let me copy the output here because it said it was too long so I added it to my original post.
    – Err
    Aug 28 '20 at 15:16
  • Not plain lsblk please. Use the whole line, sudo lsblk -o name,fstype,size,mountpoint,model,vendor, else the fs type is not shown.
    – Krackout
    Aug 28 '20 at 15:20
  • Thanks for clarifying. I just added it. The drive that has the files is the seagate and the generic is the replacement drive.
    – Err
    Aug 28 '20 at 15:25
  • I added proposals in my answer. I made some changes to your question, removed the non-helpful first pic. Also regarding downvoting, you have a point; whoever downvotes should at least make a comment why, in order for the question to be improved.
    – Krackout
    Aug 28 '20 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.