1

I used to do firefox index.html for a quick and dirty way to build simple html files locally.

Now, when I do it, the url looks right:

file:///home/me/path/to/index.html

but it doesn't load. The developer tools are blank too (tabs don't load or anything, completely blank window, won't even open if I press the keyboard shortcut), and it seems like firefox is crashing, although I haven't left it running to find out.

When I close it with the x button, it takes a second before I can launch another, saying firefox is already running.

As far as I know I didn't update it...

Happens in firefox and firefox-developer

What is wrong? How can I get terminal debug output for firefox so I can help myself?

4
  • just tried chromium, works Aug 28 '20 at 4:56
  • Just tried in a fresh Manjaro install with Firefox 79.0 and all-defaults, and it works. Please, try firefox -safe-mode or move configuration directory ~/.mozilla/firefox out of the way. Aug 28 '20 at 8:30
  • @rexkogitans, I have tried blowing out my config directory, and I've tried safe-mode as well. it worked for me up until a week or two ago. very strange. I'm going to try pacman -Syu and see if it goes back to normal, then just chalk it up to bad packages Aug 28 '20 at 16:06
  • I ended it up solving it by folding up my valuables and nuking the partition. It works now, but I'll never know the answer :( Aug 29 '20 at 1:42
1

Firefox is blocking access to local files by default. There are plugins to change this, however, they are not needed because you can configure the behaviour.

You will need to edit your user.js file which should be found in ~/.mozilla/firefox/XXXXXXXX.your_profile_name/. Add the following lines:

user_pref("capability.policy.policynames", "localfilelinks");
user_pref("capability.policy.localfilelinks.sites", "http://www.example.com");
user_pref("capability.policy.localfilelinks.checkloaduri.enabled", "allAccess");

The second line allows the website www.example.com to have links to local files. Change this to whatever website you're using.

After this change, restart Firefox.

Source

4
  • Are you sure about this? Your source seems really old (mentioning Firefox 1.5). I can (manually) go to a file:// URL in Firefox 68 ESR and the page will load. It appears OP can't even do this locally.
    – Oskar Skog
    Aug 28 '20 at 10:01
  • @OskarSkog FWIW I do this for every new Firefox I setup on Windows, atleast there it is required.
    – Panki
    Aug 28 '20 at 10:08
  • 1
    I have NoScript installed on both the host machine and the Windows VM, which invalidates my tests.
    – Oskar Skog
    Aug 28 '20 at 11:08
  • 1
    I definitely did not want to do this, as I understand it, it would allow any website to get to any file on my machine via file::// references, which is obviously a security hazard Aug 29 '20 at 1:39
1

I'm not sure why but it seems upgrading to a new Kernel of Linux solved it for me. I ran linux419 with Manjaro and had the same problem with Firefox not loading files. Now i switched to linux54 kernel and it works again as excpected. Hope it helps.

edit: if you don't know much about kernels and how to change them in Manjaro, i recommend this doc page https://wiki.manjaro.org/index.php/Manjaro_Kernels

edit2: the source on which i based this can be found here https://www.reddit.com/r/firefox/comments/iimze2/firefox_stopped_working_for_local_files/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.