5

I have an AIX server which suddenly stopped servicing SSH connections. When I try to start the service through startsrc -s sshd it says:

0513-059 The sshd Subsystem has been started. Subsystem PID is 258300.

However, right after issuing the command, the services status shows up as inoperative:

 sshd             ssh                           inoperative

The init scripts are well located and throw the same result as above.

EDIT: Here's the odmget command output:

SRCsubsys:
    subsysname = "sshd"
    synonym = ""
    cmdargs = "-D"
    path = "/usr/sbin/sshd"
    uid = 0
    auditid = 0
    standin = "/dev/console"
    standout = "/dev/console"
    standerr = "/dev/console"
    action = 1
    multi = 0
    contact = 2
    svrkey = 0
    svrmtype = 0
    priority = 20
    signorm = 15
    sigforce = 9
    display = 1
    waittime = 20
    grpname = "ssh"

When trying to start the service manually, the following error appears:

exec(): 0509-036 Cannot load program /usr/sbin/sshd because of the following errors:
0509-150   Dependent module libz.a(libz.so.1) could not be loaded.
0509-022 Cannot load module libz.a(libz.so.1).
0509-026 System error: A file or directory in the path name does not exist.

Any help would be greatly appreciated.

3 Answers 3

2

You can try the following:

1) enable LogLevel DEBUG3 in /etc/ssh/sshd_config

2) add string security.debug /var/log/syslog.security.debug rotate time 1d files 4 to /etc/syslog.conf

3) then

# touch /var/log/syslog.security.debug
# stopsrc -s syslogd
# startsrc -s syslogd
# stopsrc -s sshd
# startsrc -s sshd
9
  • I tried changing what you said, but It didn't shows any useful logging information. I check the log file after restarting syslog and ssh services but there's no information there. Jan 8, 2013 at 19:57
  • Is /var/log/syslog.security.debug empty? Does ps -elf | grep ssh get something? What errpt says?
    – dchirikov
    Jan 8, 2013 at 20:00
  • As a matter of fact, the file is empty. errpt does not show any sshd-related entries and ps -elf does not show the process running. Thank you. Jan 8, 2013 at 21:25
  • 1
    Does /var/adm/ras/syslog.caa contain some clues? If it doesnt exist touch this file and try to restart sshd.
    – dchirikov
    Jan 8, 2013 at 21:27
  • Please provide odmget -q subsysname=sshd SRCsubsys
    – dchirikov
    Jan 8, 2013 at 21:33
0

Looks like libz.so.1 is missing on your system.

1
  • Yes, it is. I will restore it to its location to see if it works. Jan 11, 2013 at 20:21
0

The problem is that there is no libz.a in /etc/opt/freeware/lib.

Use the command and find libz:

find / -name 'libz*' -exec ls -l {} \;  2>/dev/null

After, copy the library to /opt/freeware/lib/. Example:

cp /opt/freeware/lib/saveoldrpm/oldrpm/lib/libz.a /opt/freeware/lib
startsrc -s sshd 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .