I've got the following entry in my /etc/fstab:

//fritz.box/fritz.nas /mnt/smb/fritz.nas cifs   user,cache=loose,nohandlecache,username=name,workgroup=WORKGROUP,password=pwd,vers=3.0         0      0

mounting works perfectly fine, but when I want to copy a file from the server to my local machine, I get the following error:

cp: cannot open 'file.JPG' for reading: Stale file handle

or if I use rsync:

rsync: [sender] send_files failed to open "path/to/file.JPG": Stale file handle (116)
        937.29K 100%  915.32MB/s    0:00:00 (xfr#1, to-chk=0/1)

sent 88 bytes  received 35 bytes  246.00 bytes/sec
total size is 937.29K  speedup is 7,803.09
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1330) [sender=v3.2.3]

If I set the smb version to 1 the error is gone (which I'd like to avoid due to known security issues).

I already tried changing some things with the caching (since https://forums.unraid.net/topic/86707-cifs-smb-stale-file-handle/ indicates that this is causing the issue), but is isn't working. (already tried cache=none in the fstab)

Any ideas what might be causing this (maybe it isn't the caching) or what I'm doing wrong when trying to turn off the caching?

Edit: Tested downloading a file with smbclient (disabled SMBv1 in advance)

SMBv1 capability removed

smbclient works

  • 1
    Hi, are you sure that the device supports smb v3? and have you tried to copy file with smbclient?
    – binarysta
    Sep 8, 2020 at 14:55
  • I'm sure that at least v2 is supportet, since there is an extra checkbox that has to be checked so that v1 is even allowed. And I know that without checking that checkbox it works on other computers (with e.g. windows).
    – atticus
    Sep 9, 2020 at 16:28
  • 1
    ok smbclient is working for copying files without mounting?
    – binarysta
    Sep 9, 2020 at 18:19
  • Didn't tried that up to now, see the screenshots in the post for my test result (seems to be working)
    – atticus
    Sep 9, 2020 at 21:03
  • 1
    good! so could you please add noserverino in your mount options and test again?
    – binarysta
    Sep 9, 2020 at 21:54

1 Answer 1


From the question we see that it can be mounted successfully and the access to files with smbclient is ok. I suggested to add noserverino to mount options.

This option handles cases where the server can not generate a unique inode number for each file. In CIFS/SMB, files are almost always accessed (opened) by name, and it is not required that a file system be able to preserve a persistent identifier for each file (other than its name).

Some servers fill 0 for the inode number (incorrectly) making it impossible to distinguish files.

so noserverino simply tells the system that the destination is not an INODE server, so that the INODEs will be generated by the client.

  • Thanks, is there any way to give you the reputation (from the bounty) that you definitely earned even now after the bounty expired?
    – atticus
    Sep 12, 2020 at 10:36
  • 1
    Thanks, I think it should be still valid. there should be +100 near upvote. anyway new bounty also can be started if not currently available.
    – binarysta
    Sep 12, 2020 at 10:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .