0

I have been trying to install unixODBC on a new linux server running Centos 7 and I have been running into this error and I can't seem to figure out what I'm missing. We are trying to connect from UniVerse if that matters. Any IP below with X's are all the same IP.


[root@localhost /]# odbcinst -j
unixODBC 2.3.7
DRIVERS............: /etc/odbcinst.ini
SYSTEM DATA SOURCES: /etc/odbc.ini
FILE DATA SOURCES..: /etc/ODBCDataSources
USER DATA SOURCES..: /root/.odbc.ini
SQLULEN Size.......: 8
SQLLEN Size........: 8
SQLSETPOSIROW Size.: 8

odbc.ini

[root@localhost etc]# more odbc.ini
[sqlkpmint]
Driver=/opt/microsoft/msodbcsql17/lib64/libmsodbcsql-17.6.so.1.1
Description=SQL Server kpm_int
Server=xxx.xx.xx.x
Port=1433
UID=***********
PWD=***********
Language=
Database=Kpm_Int
Logging=1
LogFile=/tmp/sqlserver.log
QuotedId=Yes
AnsiNPW=Yes
Mars_Connection=Yes

odbcinst.ini

[root@localhost etc]# more odbcinst.ini
[ODBC Driver 17 for SQL Server]
Description=Microsoft ODBC Driver 17 for SQL Server
Driver=/opt/microsoft/msodbcsql17/lib64/libmsodbcsql-17.6.so.1.1
UsageCount=1

uvodbc.config


[root@localhost uv]# more uvodbc.config
#
#       This is the configuration file for the BCI and the UCI.  For more
#       information, see either the BASIC SQL Client Interface Guide or the
#       UniVerse Call Interface Guide.
#
#       This file is NOT part of UV/ODBC.  However, it can affect UV/ODBC,
#       because UV/ODBC communicates with UniVerse using the UCI.  For more
#       information, see the UV/ODBC Server Guide.
#
[ODBC DATA SOURCES]

<localuv>
DBMSTYPE = UNIVERSE
network = TCP/IP
service = uvserver
host = 127.0.0.1
<webserver>
DBMSTYPE = ODBC
network = TCP/IP
service =
host = xxx.xx.xx.x
<sqlserver>
DBMSTYPE = ODBC
network = TCP/IP
service = sqlserver
host = xxx.xx.xx.x
<sqlkpmint>
DBMSTYPE = ODBC
network = TCP/IP
service =
host = xxx.xx.xx.x

Connecting From UniVerse

connect sqlkpmint
Enter username for connecting to 'sqlkpmint' DBMS [root]: ******
Enter password for ******:
SQLConnect error:   Status = -1   SQLState = IM976   Natcode = -1
[ODBC:-1] Data source name not found, or ODBC is not installed on the system

We followed the same steps as the other server we installed and the other server works fine. The only difference is the version of ODBC. Tried reinstalling with older version and still didn't work correctly. Any advice on this would be great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.