3

I recently installed manjaro linux and the super key would simply open the whiskermenu. However, I was messing around the xfce4 keyboard shortcuts and I hit "reset to defaults" thinking it would revert to its untouched settings, but instead it reverted to some other default that made the super key open a context menu instead of the whisker menu.

The confusing part is that there isn't any visible shortcut that connects the super key to any context menu command or app. It is also worth noting that the context menu is always the one that appears when right clicking on the desktop, regardless of where my mouse is. I have managed to add a new shortcut that opens the whiskermenu when pressing the super key, but it still opens the context menu at the same time.

My keyboard shortcuts

I have tried reinstalling xfce4-settings multiple times but it hasn't changed anything at all.

EDIT: After some further testing with the xev command, I noticed that the super key is also sending an ALT_L event, which is replicated when I press the left alt key. It is also sending a bunch of other events but I'm not sure how to interpret them. enter image description here

EDIT 2: I've confirmed that the command xfdesktop --menu produces nearly identical results to pressing the super key. However, removing the ctrl+escape shortcut from the menu in picture 1 does not change anything. It seems that something somewhere is deciding to execute this command whenever I press the super key. xev also doesn't really produce anything interesting when I run xfdesktop --menu.

EDIT 3: After asking on reddit, someone suggested that xcape could be involved. I searched for xcape in the task manager and sure enough I found a process called xcape -e Super_L Alt_L F1.

enter image description here

I killed the process and it stopped the weird super key behavior. However, this process always starts whenever I log in or reboot and I don't know why. enter image description here

1
  • Although I don't know if it's the root of the problem, you may want to test with a different keyboard. Using xev to check, my keyboard sends just a SUPER_L when pressing the Super_L key. It sends what you see, including an ALT_L, only when pressing the Alt key + the Super_L key. Aug 20 '20 at 11:45
1

Go to: Menu -> Session and Startup -> [TAB] Application Autostart -> [FIND] xcape -> [UNTICK]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.