0

I have computer where I'm trying to install real-time kernel.

My OS:

# uname -a
Linux localhost.localdomain 3.10.0-1127.el7.centos.plus.i686 #1 SMP Sun Apr 5 18:08:31 UTC 2020 i686 i686 i386 GNU/Linux

I have created file /etc/yum.repos.d/CentOS-rt.repo with following content

# CentOS-rt.repo

[rt]
name=CentOS-7 - rt
baseurl=http://mirror.centos.org/centos/\$releasever/rt/\$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

When I tried to update packages I got error message, please see below

# yum update -y
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror1.hs-esslingen.de
 * extras: mirror1.hs-esslingen.de
 * updates: mirror1.hs-esslingen.de
base                                                                                                                                                                                        | 3.6 kB  00:00:00     
extras                                                                                                                                                                                      | 2.9 kB  00:00:00     
http://mirror.centos.org/centos/7/rt/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article 

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.



 One of the configured repositories failed (CentOS-7 - rt),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=rt ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable rt
        or
            subscription-manager repos --disable=rt

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=rt.skip_if_unavailable=true

failure: repodata/repomd.xml from rt: [Errno 256] No more mirrors to try.
http://mirror.centos.org/centos/7/rt/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

I have never installed kernel previously.

Please help me bypass above error.

Thank you.

6
  • Have you seen this? I'm not sure if it'll help, but it should get you pointed in the right direction. – KGIII Aug 15 '20 at 20:44
  • Does this answer your question? Install a real-time kernel on CentOS – KGIII Aug 15 '20 at 20:44
  • Thank you for you time. No, it does not answer my question. One of comment in that question has similar code, but doesn't describe how to bypass issue that I described in here. – BrilliantContract Aug 15 '20 at 21:40
  • I believe the difference is that I have i386 and they x86_4. So they didn't catch my issue. – BrilliantContract Aug 15 '20 at 21:41
  • I tried to run this code: "wget linuxsoft.cern.ch/cern/centos/7/rt/CentOS-RT.repo; yum groupinstall RT" But I end up with the same issue. – BrilliantContract Aug 15 '20 at 21:45
1

It seems that real time kernel is available on AMD64/x86_64 architectures only - yours is i386 (32 bit). Repo URLs can be accessed from a browser, so if you open CentOS 7 real time kernel or Centos real time kernel on Cern you'll see only 64 bit support. This is also confirmed on Red Hat's real time kernel installation guide, page 9, only 64 bit support. Although RHEL 7 is a 64 bit only distro with 32 bit libraries support, so no surprise. Yet I suggest you read Red Hat's doc, it'll you help understand the benefits of a real time kernel and if you really need it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.