0

I've installed a new Linux Distro (Pop!_OS) and it seems like my Windows install is currently unreachable. I've tried many things stated online and nothing seems to be working. Here's the output I see from boot-repair:

The default repair of the Boot-Repair utility would purge (in order to fix packages) and reinstall the grub2 of sda3 into the MBRs of all disks (except live-disks and removable disks without OS). Grub-efi would not be selected by default because: legacy-win no-win-efi Additional repair would be performed: unhide-bootmenu-10s win-legacy-basic-fix

Blockers in case of suggested repair:


LegacyWindows detected. Please enable BIOS-compatibility/CSM/Legacy mode in your UEFI firmware, and use this software from a live-CD (or live-USB). GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again. Alternatively, you can retry after activating the [Separate /boot/efi partition:] option.

I've tried both of these solutions and still no dice. I'm not fully sure how to enable BIOS compatibility, I have it set to see Legacy and UEFI, but I've tried many different combinations and nothing seems to get a grub screen to show up properly.

Here's my lsblk output:

➜  ~ lsblk
NAME          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda             8:0    0 465.8G  0 disk  
├─sda1          8:1    0    10M  0 part  <-- this should be the boot partition, but no dice.
├─sda2          8:2    0     4G  0 part  /recovery
├─sda3          8:3    0 457.3G  0 part  /
└─sda4          8:4    0     4G  0 part  
  └─cryptswap 253:0    0     4G  0 crypt [SWAP]
sdb             8:16   0 465.8G  0 disk  
├─sdb1          8:17   0    16M  0 part  
├─sdb2          8:18   0 465.2G  0 part  
└─sdb3          8:19   0   516M  0 part  
sdc             8:32   0 931.5G  0 disk  

Thanks!

5
  • Please edit your question to clarify which distribution and version you installed. Aug 15, 2020 at 17:01
  • Updated title and first sentence for you!
    – dardo
    Aug 15, 2020 at 17:45
  • UEFI & BIOS are not compatible. Or once you start to boot you cannot switch modes. You seem to have Windows in legacy/BIOS mode which requires MBR partitioning & Pop!_OS which uses UEFI and should be on a gpt partitioned drive. If totally separate drives, you may be able to boot, but also may have to change to BIOS boot of Windows drive and UEFI boot of Linux drive. If UEFI hardware, best to have all systems installed in UEFI boot mode.
    – oldfred
    Aug 16, 2020 at 3:47
  • Thanks for the reply! I can’t remember how windows is installed at this point. Sorry for mincing words with BIOS and UEFI.
    – dardo
    Aug 16, 2020 at 10:51
  • You can post link to Summary Report from Boot-Repair if you want more info on how systems are installed.
    – oldfred
    Aug 16, 2020 at 15:23

1 Answer 1

0

Have you tried this solution. By installing os-grober then grub-update via terminal?

> sudo apt update
> sudo apt upgrade
> sudo apt install os-prober

You well see, that os-prober will detect your Windows 10 partition after typing this,

> sudo os-prober

Finally, give GRUB command to update the partition data.

> sudo update-grub

source: dual-boot-windows-10-pop-os

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.