2

Due to shortage of free built-in SATA 3.0 plugs (6 totally) on my motherboard (Gigabyte 970A-DS3 rev.3) I've got an Adaptec RAID 5405 (3G SAS/SATA RAID) to move all "slow" SATA 1.0/2.0 devices to be connected to this card without creating any RAID. Adaptec RAID 5405 has one SFF-8087 connector and allows to connect up to 4 devices using SFF-8087 to 4 SATA cable. Now I have two devices, connected to this controller using this type of cable: DVD-RW (Plextor PX-891SA) and SATA 2.0 HDD (Hitachi HDP725050GLA360). For some reason, connected HDD is not visible as a block device and thus I can't mount the existing partition neither by using non-persistent /dev/sdXX namings, nor by using UUID (there is no such device/partition not only within /dev/disk/by-uuid but also within all dev/disk/by-* subtree). I'm running oldstable Debian Stretch 9.13.

uname -a:

Linux tekomspb 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64 GNU/Linux

lspci | grep -i adaptec shows me:

06:00.0 RAID bus controller: Adaptec AAC-RAID (rev 09)

First, I tried to discover anything from lsscsi -g:

[0:1:1:0]    disk    Hitachi  HDP725050GLA360  GM4O  -          /dev/sg0 
[0:3:0:0]    cd/dvd  PLEXTOR  DVDR   PX-891SA  1.06  /dev/sr0   /dev/sg1 
[1:0:0:0]    disk    ATA      PLEXTOR PX-128M5 1.05  /dev/sda   /dev/sg2 
[2:0:0:0]    disk    ATA      Hitachi HDP72505 A50E  /dev/sdb   /dev/sg3 
<more disks, attached to the MB SATA connectors>

The first row, sixth column says - (nothing), despite the fact that sg device is presented in /dev/ tree. I made some further research and found, that despite it is detected by HBA (both, by initial HBA BIOS at startup time and from shell using Adaptec's arcconf utility), visible in /dev as /dev/sg0, visible by smartctl, using smartctl -d sat -a /dev/sg0, it is not presented as block device in /sys. On the other hand, optical drive is quite well detected as block device both within /sys and /dev (as /dev/sr0 and /dev/sg1).

Following is the output of tree -F -d -L 3 --noreport. It is quite well seen that optical drive is detected as block device, but HDD doesn't for some reason.

/sys/devices/pci0000:00/0000:00:15.0/0000:06:00.0/host0/
├── power
├── scsi_host
│   └── host0
│       ├── device -> ../../../host0
│       ├── power
│       └── subsystem -> ../../../../../../../class/scsi_host
├── subsystem -> ../../../../../bus/scsi
├── target0:1:1
│   ├── 0:1:1:0
│   │   ├── bsg
│   │   ├── generic -> scsi_generic/sg0
│   │   ├── power
│   │   ├── scsi_device
│   │   ├── scsi_generic
│   │   └── subsystem -> ../../../../../../../bus/scsi
│   ├── power
│   └── subsystem -> ../../../../../../bus/scsi
└── target0:3:0
    ├── 0:3:0:0
    │   ├── block
    │   ├── bsg
    │   ├── driver -> ../../../../../../../bus/scsi/drivers/sr
    │   ├── generic -> scsi_generic/sg1
    │   ├── power
    │   ├── scsi_device
    │   ├── scsi_generic
    │   └── subsystem -> ../../../../../../../bus/scsi
    ├── power
    └── subsystem -> ../../../../../../bus/scsi

Output from arcconf getconfig 1:

----------------------------------------------------------------------
Physical Device information
----------------------------------------------------------------------
      Device #0
         Device is a Hard drive
         State                              : Ready
         Supported                          : Yes
         Transfer Speed                     : SATA 3.0 Gb/s
         Reported Channel,Device(T:L)       : 0,1(1:0)
         Reported Location                  : Connector 0, Device 1
         Vendor                             : Hitachi
         Model                              : HDP725050GLA360
         Firmware                           : GM4OA52A
         Serial number                      : GEAXXXXXXXXXXX
         Size                               : 476940 MB
         Write Cache                        : Enabled (write-back)
         FRU                                : None
         S.M.A.R.T.                         : No
         S.M.A.R.T. warnings                : 0
         Power State                        : Full rpm
         Supported Power States             : Full rpm,Powered off,Reduced rpm
         SSD                                : No
         MaxCache Capable                   : No
         MaxCache Assigned                  : No
         NCQ status                         : Enabled
      Device #1
         Device is a CD ROM
         Supported                          : Yes
         Transfer Speed                     : SATA 1.5 Gb/s
         Reported Channel,Device(T:L)       : 2,0(0:0)
         Vendor                             : PLEXTOR
         Model                              : DVDR   PX-891SA
         Firmware                           : 1.06

How I can fix this issue to allow HDD to be presented as block device and, thus, be mounted?

1

There is no possible to expose disk drives directly as block devices through Adaptec RAID controller. Almost all controllers from Adaptec don't support this feature - at least 5405, 5805 and, more general, a whole 3 and 5 series, though no information about 6 series of RAID controllers. Controller's BIOS doesn't allow to do this - it doesn't support HBA functionality at all.

Several folks tried to do this, but were unsuccessful.

The only thing (workaround) similar to the one described above can be done using (creating) a JBOD volume, that is going to be consisted from the only single disk.

The only exceptions that support HBA are: Adaptec Series 7 and Adaptec Series 8 Controllers (see manual). More explanation from Adaptec here

You can determine, if your controller is supported such feature by looking at it's BIOS menus. Only if the following (or similar) option: Controller Mode is presented, you can turn you RAID controller into simple HBA. Controller Mode menu If none of such options exists you can do nothing here.

1

For some reason, connected HDD [connected under the RAID Controller] is not visible as a block device and thus I can't mount the existing partition

This is normal if you have done nothing other than connect plug the disk in or connect the sata/sas cable from the raid controller to the disk.

You have to enter the RAID Controller setup screen, usually Ctrl-R, and configure it some way. A new (or used) disk will show up as Unconfigured Good typically by default- this means it is ready to be used but it won't show up in linux as you have observed.

RAID controllers vary, if yours lets you change the disk from unconfigured good to JBOD, meaning it supports the JBOD feature and not all raid cards do, then when it that disk is set to JBOD it will show up in linux as a block device such as /dev/sdb and then you can make a parition and filesystem on it and mount it like you are used to.

Otherwise you need to Create a virtual disk within the RAID card setup screen just after power up. Even if it is just one disk you create a virtual disk and it will inherently be RAID-0. Then it will show up in linux as a block device such as /dev/sdb and you can partition/file system/mount it.

# this command will list all disks in the system, including those behind
# a raid controller but only if those disks behind the raid controller have
# been configured as JBOD or a virtual disk

# Thus "unconfigured good" means just that, unconfigured, so it won't be available past the raid card setup screen

smartctl --scan
0
smartctl -d aacraid,0,0,{Drive} -i /dev/sg0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.