0

Sometimes, after booting, my sound is jittery and youtube videos are jumpy.

If I reboot, this usually (but not always) goes away.

What could cause this? Is there a log I can look at that might help to identify the failure?

EDIT:

This might have fixed it:

sudo apt-get install --reinstall alsa-base pulseaudio
pulseaudio -k && sudo alsa force-reload

Source: https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/

I will wait for another failure, and then try the fix again next time I get the sound problem.

11
  • 1
    I've got the same issue with my PC - most likely some timing bug in the ALSA HDA audio driver or PulseAudio. I can fix it without a reboot by removing all the modules responsible for sound and then loading them back which is quite annoying. Some workarounds are listed here: wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture/… and wiki.archlinux.org/index.php/PulseAudio/… – Artem S. Tashkinov Aug 13 '20 at 22:02
  • Is this only in your browser, or is sound/video a problem when played from local sources with local applications? – KGIII Aug 14 '20 at 0:46
  • @KGIII In my case it affects Chrome and Firefox but audacious and mpv work just fine. – Artem S. Tashkinov Aug 14 '20 at 11:25
  • Try disabling 'hardware acceleration' in your browser(s). You'll have to restart the browsers to see if it has any effect. – KGIII Aug 14 '20 at 17:16
  • Thanks for the tips. I have not had the problem today, but will try those solutions next time it occurs. – Ginger Aug 14 '20 at 20:22
1
+50

The title says :

Jittery sound

My question : Are you sure it is jittering ? I mean not a latency problem. This link should help you analysing.

A/ If it is authentic sound jittering then... the problem is with the clocksource. Depending on the configuration of your system (PREEMPT /HZ / NOHZ / NOHZ_FULL / cpu isolation...) the clock chosen as reference might not be reliable. Under a default kernel configuration, most MIDI sequencers will complain about it.

Human ears can detect jittering from 6ms shitfs.

B/ If it is latency, then the problem is at first with your sound server (pulseaudio as I can read in OP's comments) and second with your scheduler. As I knew it, pulseaudio is not a real-time sound server (I mean as jack can be, launched SCHED_RR) and your cpu (paticularly in cpu isolation conditions / irq threaded) might well be bothered with plenty of other things.

Exceptional ears (especially trained) can detect latency starting from 6ms shifts, audiophile connoisseurs are happy with 10ms latencies et most users of 48K audio 16bits sources wont detect anything below 16ms.

With the link I mentioned and of course taking care to choose a far more reliable sound source than chrome can be... (it should not be that difficult... ;-) the standard aplay can be considered as a good start), play some standard .wav (not needing any sort of cpu/gpu hungry decoder) push a step further in the analysis of your sound, is it A or B ? What are your kernel config parameters regarding the options I listed above ?...) I'll elaborate afterwards.

2
  • I don't think it's latency. If I change the volume using the slider in the top right of my Gnome desktop, it also makes the jittery sound. But thanks for the detailed response! – Ginger Sep 9 '20 at 21:33
  • This didn't fix it, but it helped me get there. Solution is in the original question. – Ginger Sep 10 '20 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.