2

As the title says, I've made a backup of my system before sending my laptop for tech repairs, my system was encrypted and I used CloneZilla's beginner mode so as to not mess anything up. I received my computer today and I tried to restore the image made by CloneZilla on the machine. Everything looked like it worked, but when I try to boot the machine by selecting the main drive on the boot menu, nothing happens. It juste brings me back to the BIOS boot menu. I am not greeted with any Grub or LUKS decrypt screen. I'm at a loss of ideas for what to try next, any help is greatly appreciated.

I've also tried this: FreeBSD Clonezilla Not Restoring

and

Rescatux, but for reasons which i attribute to my drive being encrypted, it cannot fix any problem and only asks to install GRUB on external drives.

Edit to answer questions: I am using EndeavourOS, an Arch Linux fork, I cloned the entire disk and verified it. Also, I restored it on the exact same drive, therefore image vs drive sizes isn't an issue. Also, after unencrypting the partitions once in a live USB, I do seem to have access to the partitions themselves.

Perhaps it is an issue with GRUB not having been reinstalled when cloning?

Thanks.

3
  • Welcome to Unix & Linux! Did you backup and restore only a single partition or the whole disk? Which distribution are you using? Please edit your question to clarify. Aug 13, 2020 at 22:36
  • 3
    I would sort out a Live Linux USB and inspect the drive to see what's there, it's impossible to know from your question what's happened or how to fix it. An Ubuntu install disk will work as a Live USB (just select "try ubuntu" after booting it). Aug 13, 2020 at 22:38
  • 1. Did you test the backup image before you sent the laptop for tech repairs? In that case you can be sure that you managed to create a restorable image, and with some patience you will be able to restore a working system; 2. Is the target drive at least as big as the original drive (not one single byte smaller)?
    – sudodus
    Aug 14, 2020 at 16:24

1 Answer 1

1

It turns out that somehow my Secure Boot was enabled in my BIOS. Turning it off solved my entire problem. Turns out the repair shop reset some settings in the BIOS...

In brief, to solve the problem, go into BIOS and disable Secure Boot.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.