3

Backstory: some Linux distributions setup a keyboard shortcut to let you enter Unicode characters, and they use CTRL + SHIFT + U as that shortcut. As a programmer, I want to instead use that shortcut in my code editor, so I'd like to disable the system one ... but I can't seem to figure out what program is responsible for it.

Everything I've found (eg. in this question about re-enabling that shortcut: How to re-enable the Ctrl+Shift+U shortcut in Cinnamon Mint 17.3?) suggests that it's dependent on my IME (input method editor). But when I went to "Input Method" (in the system menu), it said I didn't have an IME selected.

I then tried switching to the Fcitx IME (since I would like to be able to type Japanese characters), but that didn't help. Also, I went through all of the Fcitx configuration, and couldn't find any mention of a CTRL + SHIFT + U shortcut in it.

My question is: how can I disable this global CTRL + SHIFT + U shortcut? Preferably with the Fcitx IME, but if I have to disable it I can.

0
3

This is a bug listed here:

https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1885914

The solution that I found is to remove the ibus package:

$ sudo apt-get remove ibus
$ sudo apt-get purge ibus

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan and reinstall ibus:

sudo apt-get install ibus

Go to language suport and set the iBus method, for user and root

In the terminal for user and root:

ibus-setup

and change the shortcuts in the emoji tab

In the terminal for user and root:

im-config

and set ibus

For user in the terminal:

gedit .bashrc

Include the following lines at the end:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
2

I've found the solution which works:

https://superuser.com/a/1334194

Run whichever editor you have via:

GTK_IM_MODULE=xim youreditor
2
  • 1
    That's great ... on a per-app basis. Is there truly no way to disable it globally though? Aug 12 '20 at 20:52
  • You can place it in e.g. /etc/environment if you're brave enough. Or add it via /etc/profile.d/no-xim.sh - the choice is yours. Aug 12 '20 at 21:21
1

Change the keyboard shortcut in the IBus Preferences.

enter image description here

1
  • Please provide additional details in your answer. As it's currently written, it's hard to understand your solution.
    – Community Bot
    Sep 4 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.