1

I have a new notebook from a German manufacturer with a Belgian keyboard and OpenSUSE Leap 15.1. The notebook was delivered with a temporary passphrase that you can change after completing the OS setup. After finishing the setup (including selecting a Belgian keyboard layout) and rebooting, the passphrase was not accepted until I connected a German keyboard to enter it.

How can I change the system to accept a Belgian keyboard instead of German one? The passphrase contains dashes and underscores, which German keyboards map to other keys than US keyboards, so I assume the system can be set up to accept non-US keyboards.

I have looked at other LUKS passphrase questions, but I still don't know where to start.

Even though the question is formally about enabling a Belgian keyboard layout, the solution would have wider applicability, since there are many other keyboard layouts other than US querty and German quertz.

PS: I don't have this issue on my old notebook, which came from a different German reseller; it has a French keyboard and is running MX Linux.


Update in response to fra-san's comment.

The output of lsblk -fs is:

 NAME FSTYPE LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
 system-root            414.6G      2% /
 └─crypt_dev_nvme0n1p3
   └─nvme0n1p3
     └─nvme0n1
 system-swap                           [SWAP]
 └─crypt_dev_nvme0n1p3
   └─nvme0n1p3
     └─nvme0n1
 nvme0n1p1              337.5M      26% /boot
   └─nvme0n1
 nvme0n1p2              510.9M       0% /boot/efi
   └─nvme0n1

I had tried sudo cryptsetup luksAddKey crypt_dev_nvme0n1p3 and sudo cryptsetup luksAddKey nvme0n1p3, not knowing I needed to use a full path. (I'm still not sure what the full path should be, after trying a few variations begining with dev/....)

8
  • mkinitcpio is indeed a tool from Arch Linux, used there and in derivative distributions. About registering two passphrases: could you please add the relevant output from lsblk and the exact cryptsetup luksAddKey command (including the actual device) to your question? device should be the full path of the device containing the crypto_LUKS volume.
    – fra-san
    Aug 11, 2020 at 10:03
  • 1
    Is it actually LUKS encryption or regular user login? It's unusual for devices to be delivered with preinstalled LUKS. And if that was the case there are security considerations - regardless which passphrase you set, they might have your master key. Aug 11, 2020 at 10:52
  • System Language, Keyboard Layout Aug 11, 2020 at 10:53
  • @frostschutz The device was delivered with a temporary passphrase that could be used only once. After entering that and finishing the openSUSE setup, you are prompted to set a proper passphrase. This is the passphrase you are prompted for when rebooting: "Please enter passphrase for disk primary (crypt_dev_nvme0n1p3").
    – Tsundoku
    Aug 11, 2020 at 11:05
  • @frostschutz I don't have keyboard layout issues once the OS has booted.
    – Tsundoku
    Aug 11, 2020 at 11:07

1 Answer 1

2

Such issues with the keyboard layout not meeting my expectations when entering the luks password during boot keep reappearing in Leap15 for me. Therefore here my answer:

Edit KEYMAP= in /etc/vconsole.conf to match one listed in /usr/share/X11/xkb/symbols. Example:

KEYMAP=us
FONT=eurlatgr.psfu
FONT_MAP=
FONT_UNIMAP=

Run sudo mkinitrd afterwards to apply the changes.

Based on a suse forum thread.

1
  • Thanks. The issue somehow resolved itself - I don't know how. On my system, the KEYMAP value is be-latin1, which does not match exactly any of the entries in /etc/vconsole.conf (where I have, of course, a be file).
    – Tsundoku
    Aug 14, 2021 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .