2

the past days I installed a lot of software, some of them from KXStudio Repositories, after that a reboot was required, now as the computer boots up and cryptsetup appears, my passphrase is not recognized. In the elementary OS installation I set configured the keyboard for Latin American layout (Spanish) and my password for cryptsetup is:

==?#!123qwe22

At boot up I tried using the keys that would match the first characters if I used a US keyboard layout, but is not working. Now I'm booting with a live CD and I tried

echo -n '==?#!123qwe22' | cryptsetup luksOpen /dev/sda3 sda3_crypt

But is not working... (No key available with this passphrase.)

Here is the output from this command

cryptsetup --debug luksOpen /dev/sda3 sda3_crypt

 cryptsetup 2.0.2 processing "cryptsetup --debug luksOpen /dev/sda3 sda3_crypt"
 Running command open.
 Locking memory.
 Installing SIGINT/SIGTERM handler.
 Unblocking interruption on signal.
 Allocating context for crypt device /dev/sda3.
 Trying to open and read device /dev/sda3 with direct-io.
 Initialising device-mapper backend library.
 Trying to load any crypt type from device /dev/sda3.
 Crypto backend (gcrypt 1.8.1) initialized in cryptsetup library version 2.0.2.
 Detected kernel Linux 5.3.0-53-generic x86_64.
 PBKDF pbkdf2, hash sha256, time_ms 2000 (iterations 0), max_memory_kb 0, parallel_threads 0.
 Reading LUKS header of size 1024 from device /dev/sda3
 Key length 64, device size 1462597632 sectors, header size 4036 sectors.
 Activating volume sda3_crypt using token -1.
 Interactive passphrase entry requested.
Enter passphrase for /dev/sda3:
 Activating volume sda3_crypt [keyslot -1] using passphrase.
 dm version   [ opencount flush ]   [16384] (*1)
 dm versions   [ opencount flush ]   [16384] (*1)
 Detected dm-ioctl version 4.40.0.
 Device-mapper backend running with UDEV support enabled.
 dm status sda3_crypt  [ opencount flush ]   [16384] (*1)
 Trying to open key slot 0 [ACTIVE_LAST].
 Reading key slot 0 area.
 Using userspace crypto wrapper to access keyslot area.
 Trying to open key slot 1 [INACTIVE].
 Trying to open key slot 2 [INACTIVE].
 Trying to open key slot 3 [INACTIVE].
 Trying to open key slot 4 [INACTIVE].
 Trying to open key slot 5 [INACTIVE].
 Trying to open key slot 6 [INACTIVE].
 Trying to open key slot 7 [INACTIVE].
No key available with this passphrase.
 Interactive passphrase entry requested.

I would be very grateful if you could help me, I am desperate :( Thank you

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.