0

I'm trying to run sudo dnf system-upgrade download --refresh --releasever=30 --allowerasing (from fedora 25) and hitting the following errors.

Running transaction check
Error: transaction check vs depsolve:
(php-composer(symfony/expression-language) >= 2.8 with php-composer(symfony/expression-language) < 5) is needed by php-phpmyadmin-motranslator-4.0-4.fc30.noarch
(gcc >= 9 with gcc < 10) is needed by annobin-8.71-4.fc30.x86_64
(php-composer(symfony/translation) >= 2.7.1 with php-composer(symfony/translation) < 4.0) is needed by php-twig-extensions-1.5.4-4.fc30.noarch
(php-composer(twig/twig) >= 1.27 with php-composer(twig/twig) < 3.0) is needed by php-twig-extensions-1.5.4-4.fc30.noarch
(php-composer(symfony/polyfill-mbstring) >= 1.3 with php-composer(symfony/polyfill-mbstring) < 2) is needed by php-twig2-2.12.5-1.fc30.noarch
(php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2) is needed by composer-1.10.6-1.fc30.noarch
(php-composer(composer/semver) >= 1.0 with php-composer(composer/semver) < 2) is needed by composer-1.10.6-1.fc30.noarch
(php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2) is needed by composer-1.10.6-1.fc30.noarch
(php-composer(composer/xdebug-handler) >= 1.1 with php-composer(composer/xdebug-handler) < 2) is needed by composer-1.10.6-1.fc30.noarch
(php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2) is needed by composer-1.10.6-1.fc30.noarch
(php-composer(seld/jsonlint) >= 1.4 with php-composer(seld/jsonlint) < 2) is needed by composer-1.10.6-1.fc30.noarch
(php-composer(seld/phar-utils) >= 1.0 with php-composer(seld/phar-utils) < 2) is needed by composer-1.10.6-1.fc30.noarch
(php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2.0) is needed by php-symfony-console-2.8.52-1.fc30.noarch
(php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2.0) is needed by php-symfony-http-kernel-2.8.52-1.fc30.noarch
(php-composer(symfony/polyfill-php56) >= 1.8 with php-composer(symfony/polyfill-php56) < 2.0) is needed by php-symfony-http-kernel-2.8.52-1.fc30.noarch
(php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2.0) is needed by php-symfony-debug-2.8.52-1.fc30.noarch
(php-composer(symfony/polyfill-php54) >= 1.8 with php-composer(symfony/polyfill-php54) < 2.0) is needed by php-symfony-http-foundation-2.8.52-1.fc30.noarch
(php-composer(symfony/polyfill-php55) >= 1.8 with php-composer(symfony/polyfill-php55) < 2.0) is needed by php-symfony-http-foundation-2.8.52-1.fc30.noarch
(php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2) is needed by php-composer-xdebug-handler-1.4.1-1.fc30.noarch
(php-composer(dasprid/enum) >= 1.0 with php-composer(dasprid/enum) < 2) is needed by php-bacon-qr-code2-2.0.0-1.fc30.noarch
(php-composer(paragonie/constant_time_encoding) >= 1.0 with php-composer(paragonie/constant_time_encoding) < 3) is needed by php-pragmarx-google2fa5-5.0.0-1.fc30.noarch
(php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3) is needed by php-pragmarx-google2fa5-5.0.0-1.fc30.noarch
(php-composer(google/recaptcha) >= 1.1 with php-composer(google/recaptcha) < 2) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(phpmyadmin/motranslator) >= 4.0 with php-composer(phpmyadmin/motranslator) < 5) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(phpmyadmin/shapefile) >= 2.0 with php-composer(phpmyadmin/shapefile) < 3) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(phpmyadmin/sql-parser) >= 4.3.2 with php-composer(phpmyadmin/sql-parser) < 5) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(phpseclib/phpseclib) >= 2.0.9 with php-composer(phpseclib/phpseclib) < 3) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(symfony/expression-language) >= 2.8 with php-composer(symfony/expression-language) < 4) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(symfony/polyfill-mbstring) >= 1.3 with php-composer(symfony/polyfill-mbstring) < 2) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(twig/extensions) >= 1.5.1 with php-composer(twig/extensions) < 2) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
(php-composer(twig/twig) >= 1.34 with php-composer(twig/twig) < 3) is needed by phpMyAdmin-4.9.5-1.fc30.noarch
To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue.
Download complete! Use 'dnf system-upgrade reboot' to start the upgrade.
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

TBH I really don't care about PHP. I'd be surprised if everything can't just be dnf installed after the upgrade finishes and it's not like core system packages are listed so the system should be happy without them. Is there an --i-dont-care-just-do-it option? (more than --allowerasing)

If not I'd happily uninstall the packages listed so dnf doesn't try to upgrade them and fail miserably. I've tried to sudo dnf remove <a bunch of these> but nothing is working:

No match for argument: php-phpmyadmin-motranslator
No match for argument: annobin
No match for argument: php-twig-extensions
No match for argument: php-twig2
No match for argument: composer
No match for argument: php-symfony*
No match for argument: php-composer*

What else can I try?


EDIT

I think the reason these packages don't exist is they're proposed replacements to some existing package. DNF should be printing the source packages and explaining how it got itself into this state. Otherwise it's just a total guessing game.

1 Answer 1

1

This could work:

 dnf remove '*php*'
3
  • Thanks! I removed php sounding packages until most of the errors went away. I'm still stuck with annobin. I have figured out I can --exclude=annobin although this might be catastrophic if annobin is actually a dependency of dnf after the system upgrade complets.
    – jozxyqk
    Commented Aug 9, 2020 at 18:21
  • annobin is a dependency for building RPM packages so you can erase it as well to avoid upgrade issues and then install it back again. Commented Aug 9, 2020 at 18:28
  • Thanks! Looks like something installed it for me afterwards anyway as it was there after upgrading (despite sudo dnf system-upgrade ... --exclude=annobin).
    – jozxyqk
    Commented Aug 9, 2020 at 23:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .