0

I want to disable Jenkins auto login. When I open the jenkins on browser like http://192.168.5.15:8080 , it does not ask user id and password .

when I go to Manage Jenkins > Configure Global Security > there I do not get an option to tick out Enable Security

enter image description here

1 Answer 1

0

Your security realm is set to None. You can't enable security (i.e. account login) if you have no user accounts. You need to tell Jenkins where to look for user accounts.

If you want to use your local machine's credentials, use "Unix user/group database". If you created an admin account during setup, then it was probably stored in "Jenkin's own user database". I use LDAP to connect with my organization's active directory.


To be sure this answer is correct, I installed a fresh instance of Jenkins on a debian system and set up an initial admin user. Then I set "Security Realm" = None and "Authorization"=Anyone can do anything. In this situation, I was able to access the security settings in an incognito browser (no login). I think this is the same situation you have.

Next I selected: "Security Realm"=Jenkins’ own user database with Authorization=Logged-in users can do anything and ensured that Allow anonymous read access was not selected.

I refreshed my incognito browser and I had a sign-in prompt, requiring login before I could see anything at all. I confirm that I could login with the admin-account I created during installation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .