2

I have an X1 Carbon (Gen) running 5.7.12-arch1-1 kernel with Wayland/Gnome. When I click to select text in any application, the mouse tends to lose the depressed click before I have finished selecting the text. When I move the mouse more slowly, the select process is more reliable. It is like the input from the mouse is not being consistently registered or that the act of clicking and holding the mouse is somehow being forgotten.

The problem seems to vary in severity. This problem did not exist when I first installed Arch but I am unable to diagnose what installation/upgrade caused the change. I have a Logitech USB mouse plugged directly into the laptop usb port.

I am at a loss to figure out how to debug this problem. I have only recently switched from Ubuntu to Arch so even knowing what logs to look at is challenging. Any pointers, suggestions gratefully received.

6
  • Have you tried a different mouse, or the built in one on your laptop? – Time4Tea Aug 6 '20 at 19:12
  • Yes, the problem does not seem to be in the peripheral. – SteveSong Aug 7 '20 at 1:20
  • Ok, it probably isn't the mouse driver then, as I think typically the built-in trackpad would use a different kernel module. I use Arch myself, but with X. I haven't used Wayland. So, it could be an issue with Wayland? Perhaps try installing the X version of Gnome or LXDE, to see if it works ok with X? – Time4Tea Aug 7 '20 at 11:42
  • I switched to the X version of Gnome and things seemed better at first but I find it still happens. – SteveSong Aug 17 '20 at 13:30
  • All I can suggest is that you try different things to use the process of elimination to pinpoint where the issue is. If you have tried different mouse devices and both X and Wayland give the problem, then I'm not sure what else it could be. I would probably try making a bootable USB for another distro (Ubuntu, Mint) and see if you get the same issue with that. It seems very bizarre. – Time4Tea Aug 17 '20 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.