1

I have an internal SSD (NVMe) on which I've installed Ubuntu 18.04 with Full Encryption using LUKS. Recently, I replaced the motherboard of my laptop which caused the signature verification of the kernel to get failed during boot.

error: /boot/vmlinuz-****-generic has invalid signature
error: you need to load the kernel first

If I tried to boot without secure boot then it gets past the signature verification, but later during boot process, I get an error that says "cryptsetup: lvm is not available".

So, in order to fix the signature verification issue that occurs with secure boot, I read that I need to add a newly signed kernel into the boot partition using a live USB. However, after booting into the Live OS (Ubuntu) I couldn't find the NVMe drive at all. I checked the /dev location and used several tools such as gparted, fdisk, lsblk. I just couldn't get the drive listed with any of these tools.

May I know why the drive is not getting detected? And how to get this drive mounted? I am also not sure why the "cryptsetup: lvm is not available" issue occurs.

PS: I tried booting up WindowsToGo (Windows 10) and from it, I was able to find the SSD drive being listed under "Disk Management" utility. So, I don't think it is an issue with the SSD. It is functional. I am just not able to get this drive listed with Live Linux.

1

1 Answer 1

1

I finally fixed the issue.

The issue occurred since the BIOS settings of SATA Operation was defaulted to RAID On mode instead of AHCI mode, with the newly replaced motherboard.

So, basically changing the SATA Operation to AHCI and then disabling Secure Boot(to get rid of Invalid Kernel Signature) fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .