2

I installed a locally compiled version of OpenSSL and I forgot to skip the man pages. Now I can't access the man page for the OS's passwd(1).

  • OS: Raspberry's Debian Stretch (with GUI)
  • OpenSSL: 1.1.1g

Using apropos gave me a hint that there are also extensions to be browsed with -e flag (man man):

passwd(1)    - change user password
passwd(1ssl) - compute password hashes

However, none of the following worked for me

  • man passwd
  • man 1 passwd (from answer but still doesn't work)
  • man -s 1 passwd
  • man -s 1 -e '' passwd
  • man -s 1 -e posix passwd

It seems that man will default to the ssl extension, which makes me wonder... How can I look at the original passwd(1) man page?

Note: no uninstalling allowed.

4
  • 1
    What Operating System is it? Aug 4, 2020 at 16:42
  • I am working on an R-Pi with Debian Buster
    – hanzo2001
    Aug 4, 2020 at 18:46
  • Can you please share the output of man -f passwd (which should list passwd(1) and passwd(1ssl), as you already posted) and man -aw passwd? (Hoping your man version supports these options). I suspect you have two files named passwd.1.gz (actually, more than one passwd.1, with an optional extension) in distinct directories and that your question has been misread.
    – fra-san
    Aug 29, 2020 at 11:30
  • Depending on your man implementation you may be interested in Why man -k or Apropos cannot find some pages while man -a can?
    – fra-san
    Sep 29, 2020 at 21:25

2 Answers 2

5

You were close - don't use any flag, just man <section> command:

$ man 1 passwd
...
$ man 1ssl passwd
...

(I confirmed this on Ubuntu 20.04, which happens to default to section 1 when none specified.)

4
  • I hopped into the terminal and tested it. It does not work. man 1 passwd still shows the entry for openssl-passwd
    – hanzo2001
    Aug 4, 2020 at 18:47
  • That's weird; I've been using the man command in that way since 1995 on SunOS. Check man man - it should say something like man [section] command where section is optional. Do you have man aliased in some way? What does type -f man tell you? Aug 4, 2020 at 19:43
  • man [man options] [[section] page ...] ... man7.org/linux/man-pages/man1/man.1.html Aug 4, 2020 at 19:45
  • type -f man outputs man is /usr/bin/man
    – hanzo2001
    Aug 6, 2020 at 7:43
1

I found a temporary solution with the -a flag and skip the OpenSSL page

1
  • If anybody proposes something better, I'll mark it as the answer
    – hanzo2001
    Aug 4, 2020 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .